Bug 35015 - The requested operation has failed
Summary: The requested operation has failed
Status: RESOLVED DUPLICATE of bug 18334
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_auth_ldap (show other bugs)
Version: 2.0.54
Hardware: PC Windows XP
: P2 critical (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-23 05:02 UTC by ddcopy
Modified: 2005-10-04 09:47 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ddcopy 2005-05-23 05:02:48 UTC
After I modified the line in httpd.conf

"LoadModule auth_ldap_module modules/mod_auth_ldap.so"

and reboot the apache server, error message popup:

"The requested operation has failed!"

Version: apache 2.0.54 for windows
Comment 1 Paul Querna 2005-06-03 00:07:00 UTC
What does the error log say?  This sounds like a user support issue.
Comment 2 Nick Kew 2005-08-29 00:21:20 UTC
No feedback in nearly 3 months NEEDINFO; closing. 
Comment 3 ddcopy 2005-08-31 10:57:04 UTC
I want to use APACHE + LDAP + Subversion.
Ver: APACHE 2.0.54, LDAP 2.2.19, SVN 1.2.1

When I restart httpd, the error.log file :

#=======================================
[Wed Aug 31 16:45:36 2005] [warn] pid file C:/DevSrv/Apache2/logs/httpd.pid 
overwritten -- Unclean shutdown of previous Apache run?
[Wed Aug 31 16:45:36 2005] [notice] LDAP: Built with Microsoft LDAP SDK
[Wed Aug 31 16:45:37 2005] [notice] LDAP: SSL support available
[Wed Aug 31 16:45:37 2005] [notice] Apache/2.0.54 (Win32) DAV/2 PHP/4.4.0 
SVN/1.2.1 configured -- resuming normal operations
[Wed Aug 31 16:45:37 2005] [notice] Server built: Apr 16 2005 14:25:31
[Wed Aug 31 16:45:37 2005] [notice] Parent: Created child process 3124
[Wed Aug 31 16:45:37 2005] [notice] LDAP: Built with Microsoft LDAP SDK
[Wed Aug 31 16:45:38 2005] [notice] LDAP: SSL support available
[Wed Aug 31 16:45:38 2005] [notice] Child 3124: Child process is running
[Wed Aug 31 16:45:38 2005] [notice] Child 3124: Acquired the start mutex.
[Wed Aug 31 16:45:38 2005] [notice] Child 3124: Starting 250 worker threads.
#=======================================

And then I can visit some application in my local server.

When I visit "http://localhost/svn/", error message window popup:
"The requested operation has failed!", and then, the server down!

The next line add to error.log :
[Wed Aug 31 16:52:35 2005] [notice] Parent: child process exited with status 
3221225477 -- Restarting.


httpd.conf :
#========================
Include conf/develop.conf
#========================

develop.conf :
#========================
AddDefaultCharset GB2312

DirectoryIndex index.php

PHPIniDir "C:/DevSrv/php/"
AddType application/x-httpd-php .php
LoadModule php4_module "C:/devsrv/php/sapi/php4apache2.dll"

LoadModule ldap_module modules/util_ldap.so
LoadModule auth_ldap_module modules/mod_auth_ldap.so

LoadModule dav_svn_module "C:/DevSrv/Subversion/bin/mod_dav_svn.so"
LoadModule authz_svn_module "C:/DevSrv/Subversion/bin/mod_authz_svn.so"

Alias /webapp/ "C:/DevSrv/webapp/"

<Directory "C:/DevSrv/webapp">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

<Location /svn>
    DAV svn
    SVNPath C:/SVN
    AuthType Basic
    AuthName "Subversion repository"

    AuthLDAPEnabled on
    AuthLDAPAuthoritative on
    AuthLDAPURL ldap://localhost/ou=users,dc=MY_DOMAIN,dc=com,dc=cn?uid?sub?
(objectClass=*)
    require valid-user
</Location>
#========================
Comment 4 Joe Orton 2005-10-04 17:47:32 UTC
Given no more diagnosis, "mod_auth_ldap crashes with MS LDAP SDK" is the same as
bug 18334.

*** This bug has been marked as a duplicate of 18334 ***