Bug 35021 - Bug in configure test for SCTP - missing headers
Summary: Bug in configure test for SCTP - missing headers
Status: RESOLVED FIXED
Alias: None
Product: APR
Classification: Unclassified
Component: APR (show other bugs)
Version: HEAD
Hardware: All Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache Portable Runtime bugs mailinglist
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2005-05-23 15:50 UTC by Lee Begg
Modified: 2005-09-08 07:35 UTC (History)
1 user (show)



Attachments
Patch to fix sctp test in apr_network.m4 (449 bytes, patch)
2005-05-23 15:53 UTC, Lee Begg
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lee Begg 2005-05-23 15:50:33 UTC
The current test in build/apr_network.m4 does not give sctp a fair chance to 
be configured because it does not try to include the SCTP related headers that 
have been tested for. 
 
I have a 6 line (plus context) patch that fixes this problem. I will attach it 
in a moment.
Comment 1 Lee Begg 2005-05-23 15:53:47 UTC
Created attachment 15132 [details]
Patch to fix sctp test in apr_network.m4

Diff'ed in an apache (2.1.54, apr 0.9.6) tree (sorry).
I have checked it against both head, and 1.1.1 and it is still valid
Comment 2 Lee Begg 2005-06-03 10:43:49 UTC
Added "missing headers" to the summary of the bug as that is all it is. 
Comment 3 Joe Orton 2005-06-03 15:39:04 UTC
Committed for future release.
Comment 4 Joe Orton 2005-09-08 15:35:04 UTC
*** Bug 35334 has been marked as a duplicate of this bug. ***