Bug 35164 - NPE on Remote clients running in Non-Gui mode (JDBC sampler)
Summary: NPE on Remote clients running in Non-Gui mode (JDBC sampler)
Status: RESOLVED DUPLICATE of bug 39792
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.0.3
Hardware: PC Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-02 01:13 UTC by Mark Drilling
Modified: 2007-09-01 05:00 UTC (History)
0 users



Attachments
host jmeter.log (2.44 KB, application/octet-stream)
2005-06-02 16:27 UTC, Mark Drilling
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Drilling 2005-06-02 01:13:11 UTC
I get the following exception on the remote clients when running multiple 
remote clients in non-Gui mode:
java.lang.NullPointerException
  at org.apache.jorphan.collections.HashTree.traverseInto(HashTree.java:1012)
  at org.apache.jorphan.collections.HashTree.traverse(HashTree.java:990)
  at org.apache.jmeter.engine.StandardJMeterEngine.run
(StandardJMeterEngine.java:330)
  at java.lang.Thread.run(Unknown Source)

Im using the JDBC sampler.  Here is the command line -
jmeter -n -r -Jremote_hosts=client1,client2 -tC:\in.jmx -lC:\out.jtl
Comment 1 Sebb 2005-06-02 01:47:46 UTC
Does this also happen with other samplers, e.g. the JavaTest sampler?

Does it happen straight away, or only after the test has started running?

Any messages in the console windows (apart from JVM garbage collection info)?
Comment 2 Mark Drilling 2005-06-02 16:27:11 UTC
Created attachment 15262 [details]
host jmeter.log
Comment 3 Mark Drilling 2005-06-02 16:27:51 UTC
(In reply to comment #1)
> Does this also happen with other samplers, e.g. the JavaTest sampler?
> Does it happen straight away, or only after the test has started running?
> Any messages in the console windows (apart from JVM garbage collection info)?

I havent tried with other samplers.  I can run multiple remote clients 
successfully from the GUI - but when I run the same case from command line, I 
get this error.
It happens right away.  I get the exception on the remote client and the 
controlling process hangs.  Nothing else of interest is in the remote logs or 
console.  I am attaching the host jmeter.log - there is a different exception.
  
Comment 4 bradley lee 2005-12-21 02:40:06 UTC
I have a similar problem.  Just testing whether I can add additional 
information.
Comment 5 bradley lee 2005-12-21 02:56:58 UTC
I am also two problems when when running multiple remote clients in non-Gui 
mode.  My command line (have also tried through Ant which has same problems):
java -jar ApacheJMeter.jar -n -r -
p //Ct38i/shared/AutoTest/Jmeter/bin/jmeter.properties -d C:/jakarta-jmeter-
2.1.1 -t //Ct38i/shared/AutoTest/Jmeter/AntLoadTest.jmx -
l //Ct38i/shared/AutoTest/results_template/JMeterResults.jtl -
JtestId=ES1_W1_T1 -Jrequest.threads=3 -Jrequest.loop=4 -
Jrequest.plan=ES1control.bsh -Jrequest.testPlanDir=//Ct38i/shared/AutoTest/

Problem 1.  The test case uses the parameters but the parameters are not 
passed to the remote machine.  

Problem 2.  The test runs successfully (the log and results output is as 
expected). However, the test hangs.  My output is:
Created the tree successfully
Configuring remote engine for 150.151.223.196
Starting remote engines
Remote engines have been started
Tidying up ...
... end of run

2005/12/21 12:51:06 INFO  - jmeter.util.JMeterUtils: Setting Locale to en_AU 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Setting JMeter property: 
testId=ES1_W1_T1 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Setting JMeter property: 
request.threads=3 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Setting JMeter property: 
request.loop=4 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Setting JMeter property: 
request.plan=ES1control.bsh 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Setting JMeter property: 
request.testPlanDir=//Ct38i/shared/AutoTest/ 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Version 2.1.1 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: java.version=1.4.2_03 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Locale=English (Australia) 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Copyright (c) 1998-2005 The Apache 
Software Foundation 
2005/12/21 12:51:06 INFO  - jmeter.JMeter: Loading file: 
\\Ct38i\shared\AutoTest\Jmeter\AntLoadTestxx.jmx 
2005/12/21 12:51:07 INFO  - jmeter.samplers.SampleResult: Note: Sample 
TimeStamps are END times 
2005/12/21 12:51:07 INFO  - jmeter.samplers.SampleResult: 
sampleresult.default.encoding is set to ISO-8859-1 
2005/12/21 12:51:07 INFO  - jmeter.protocol.http.sampler.HTTPSampler2: 
httpsampler2.basicauth=false 
2005/12/21 12:51:07 INFO  - jmeter.save.SaveService: Using SaveService 
properties file 1.7 
2005/12/21 12:51:07 INFO  - jmeter.save.SaveService: All converter versions 
present and correct 
2005/12/21 12:51:07 INFO  - jmeter.engine.ClientJMeterEngine: about to run 
remote test 
2005/12/21 12:51:07 INFO  - jmeter.engine.ClientJMeterEngine: done initiating 
run command 
2005/12/21 12:51:07 INFO  - jmeter.engine.ClientJMeterEngine: running 
clientengine run method 
2005/12/21 12:51:07 INFO  - jmeter.engine.ConvertListeners: num threads = 1 
2005/12/21 12:51:07 INFO  - jmeter.engine.ConvertListeners: num threads = 2 
2005/12/21 12:51:07 INFO  - jmeter.engine.ConvertListeners: num threads = 1 
2005/12/21 12:51:07 INFO  - jmeter.samplers.StandardSampleSender: Using 
Standard Remote Sampler for this test run 
2005/12/21 12:51:07 INFO  - jmeter.samplers.StandardSampleSender: Using 
Standard Remote Sampler for this test run 
2005/12/21 12:51:07 INFO  - jmeter.samplers.StandardSampleSender: Using 
Standard Remote Sampler for this test run 
2005/12/21 12:51:07 INFO  - jmeter.engine.ConvertListeners: num threads = 1 
2005/12/21 12:51:07 INFO  - jmeter.engine.ConvertListeners: num threads = 2 
2005/12/21 12:51:07 INFO  - jmeter.engine.ConvertListeners: num threads = 1 
2005/12/21 12:51:07 INFO  - jmeter.engine.ClientJMeterEngine: sent host 
=150.151.223.196 
2005/12/21 12:51:07 INFO  - jmeter.engine.ClientJMeterEngine: sent test 
2005/12/21 12:51:07 INFO  - jmeter.engine.ClientJMeterEngine: sent run command 
2005/12/21 12:51:07 INFO  - jmeter.JMeter: Started remote host: 
150.151.223.196 
2005/12/21 12:51:22 INFO  - jmeter.JMeter: Remote host 150.151.223.196 
finished 


Trying to use JBuilder to step through the JMeter code so will let u know if I 
find anything.
Cheers
Brad
Comment 6 Sebb 2007-09-01 05:00:17 UTC
Seems to be same as other remote engine crashes

*** This bug has been marked as a duplicate of 39792 ***