Bug 35234 - Make the javah task fall back to executing javah command
Summary: Make the javah task fall back to executing javah command
Status: RESOLVED FIXED
Alias: None
Product: Ant
Classification: Unclassified
Component: Optional Tasks (show other bugs)
Version: 1.6.2
Hardware: Other other
: P2 enhancement (vote)
Target Milestone: 1.8.2
Assignee: Ant Notifications List
URL:
Keywords: PatchAvailable
Depends on:
Blocks:
 
Reported: 2005-06-06 11:43 UTC by Gary Benson
Modified: 2016-07-30 16:48 UTC (History)
1 user (show)



Attachments
Patch (1.85 KB, patch)
2005-06-06 11:44 UTC, Gary Benson
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gary Benson 2005-06-06 11:43:10 UTC
The attached patch modifies the javah task to make it fall back to executing the
javah command if it cannot be run inprocess, for example if
com.sun.tools.javah.Main cannot be found.  This is required for gcj users, and
may be useful to users of other non-Sun JDKs too.
Comment 1 Gary Benson 2005-06-06 11:44:11 UTC
Created attachment 15310 [details]
Patch
Comment 2 Matt Benson 2005-06-06 16:55:26 UTC
If this patch is made against Ant 1.6.2 source it will be sorely out-of-date 
from Ant CVS HEAD.  There has been much refactoring from 1.6.2 to 1.6.3-4.
Comment 3 Gary Benson 2005-06-06 17:06:19 UTC
I should be updating to 1.6.5 within the next couple of weeks.  I can post an
updated patch then...
Comment 4 Alexey Solofnenko 2005-06-06 17:50:16 UTC
I believe all patches should be against HEAD.
Comment 5 Curt Arnold 2007-02-20 23:23:45 UTC
*** Bug 36587 has been marked as a duplicate of this bug. ***
Comment 6 Stefan Bodewig 2016-07-30 16:48:14 UTC
This patch has been neglected for long enough that it has become irrelevant. I'm sorry about this.

Ant 1.8.2 has added support for gcjh which has superseeded this ticket. Ant 1.9.8 adds support for a forked javah with git commit 7ebbdc9.