Bug 35471 - need to add remoteVerificationEnabled attribute to FTP task to avoid firewall errors
Summary: need to add remoteVerificationEnabled attribute to FTP task to avoid firewall...
Status: RESOLVED FIXED
Alias: None
Product: Ant
Classification: Unclassified
Component: Optional Tasks (show other bugs)
Version: 1.6.2
Hardware: Other Windows XP
: P3 enhancement (vote)
Target Milestone: 1.8.0
Assignee: Ant Notifications List
URL:
Keywords: PatchAvailable
: 29741 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-06-22 18:15 UTC by Viacheslav Garmash
Modified: 2008-07-14 07:43 UTC (History)
1 user (show)



Attachments
example of code to insert (1.19 KB, text/plain)
2005-06-22 18:25 UTC, Viacheslav Garmash
Details
Jar from Eclipse Ant plugin that contain patched FTP class (34.94 KB, patch)
2005-06-22 18:32 UTC, Viacheslav Garmash
Details | Diff
Instruction for Eclipse users (637 bytes, text/plain)
2005-06-22 18:33 UTC, Viacheslav Garmash
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viacheslav Garmash 2005-06-22 18:15:58 UTC
Hello all!

Some days ago I decided to use FTP Ant task for automatize some deployment 
tasks. In local network all works fine but when I tried to deloy to remote 
server (outside our firewall) I have caught an IOException:

"Host attempting data connection xxx.xxx.xxx.xx2 is not same as server 
xxx.xxx.xxx.xx1"

where xxx.xxx.xxx.xx2 is IP of our firewall and xxx.xxx.xxx.xx1 IP of remote 
server. Setproxy didn't help at all...

In Google Groups I have found solution for our problem: 
http://groups.google.com/groups?
hl=ru&lr=&threadm=pan.2005.05.11.07.52.37.118599%
40libero.it&rnum=1&prev=/groups%3Fq%3D%2522is%2Bnot%2Bsame%2Bas%2Bserver%2522%
2Bcommons%26hl%3Dru%26lr%3D%26selm%3Dpan.2005.05.11.07.52.37.118599%
2540libero.it%26rnum%3D1
To apply this solution I have to setRemoteVerificationEnabled(false). But this 
property still not changeble from Ant and what is more this problem exists in 
Ant some years (look here: http://www.mail-archive.com/ant-
user@jakarta.apache.org/msg20460.html - the same problem without solution from 
2002 year). But this is rare problem: only 5 questions in Google: 
http://www.google.com/search?ie=windows-1251&q=%
22Host+attempting+data+connection%22++%22is+not+same+as+server%22
That's why no solution till now.

So. To resolve this problem I have add remoteVerificationEnabled attribute to 
FTP task (see attached diff file). And now ftp works perfectly behind firewall. 
I think this attribute will be very useful for everybody. Please, add this 
attribute to next version of Ant.

Best Regards,

-- 
Viacheslav Garmash
Team Leader
Exadel Inc.
e-mail: vgarmash@exadel.com
phone       +375 17 2626260 ext. 106
cellular    +375 29 4038657
Comment 1 Viacheslav Garmash 2005-06-22 18:25:43 UTC
Created attachment 15515 [details]
example of code to insert
Comment 2 Viacheslav Garmash 2005-06-22 18:32:16 UTC
Created attachment 15516 [details]
Jar from Eclipse Ant plugin that contain patched FTP class
Comment 3 Viacheslav Garmash 2005-06-22 18:33:02 UTC
Created attachment 15517 [details]
Instruction for Eclipse users
Comment 4 Viacheslav Garmash 2005-06-22 18:36:37 UTC
This is easy enhancement. I think it possible to add it to next build.
Comment 5 Stefan Bodewig 2008-07-14 07:31:38 UTC
subversion revision 676603
Comment 6 Stefan Bodewig 2008-07-14 07:43:22 UTC
*** Bug 29741 has been marked as a duplicate of this bug. ***