Bug 35656 - Setting the property "width" on cell does not take effect.
Summary: Setting the property "width" on cell does not take effect.
Status: CLOSED FIXED
Alias: None
Product: Fop - Now in Jira
Classification: Unclassified
Component: page-master/layout (show other bugs)
Version: 0.20.5
Hardware: Other other
: P2 normal
Target Milestone: ---
Assignee: fop-dev
URL:
Keywords:
: 38777 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-07-08 09:04 UTC by maco
Modified: 2012-04-01 06:41 UTC (History)
1 user (show)



Attachments
fo file (2.40 KB, text/xml)
2005-07-08 09:06 UTC, maco
Details
pdf file (1.35 KB, application/pdf)
2005-07-08 09:06 UTC, maco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description maco 2005-07-08 09:04:41 UTC
In the attached XSL-FO, the table has three columns whose widths are all set 
to 1in. And I set the property width of the cell which is located in the first 
row and the second column to 2in. However the produced PDF shows that the 
widths of the three columns are still equal and the property "width" on cell 
does not take effect.
Comment 1 maco 2005-07-08 09:06:30 UTC
Created attachment 15618 [details]
fo file
Comment 2 maco 2005-07-08 09:06:52 UTC
Created attachment 15619 [details]
pdf file
Comment 3 Jeremias Maerki 2005-07-08 09:38:23 UTC
FOP doesn't support getting column widths from the first table row as 
described in http://www.w3.org/TR/CSS2/tables.html#width-layout, yet. Even the 
current development code doesn't do that, yet.

As a work-around you'll have to specify the column widths directly on the 
table-column nodes instead.

I'll leave the bug open as a reminder to implement that in FOP trunk.
Comment 4 Manuel Mall 2006-02-24 06:21:52 UTC
*** Bug 38777 has been marked as a duplicate of this bug. ***
Comment 5 Andreas L. Delmelle 2006-08-21 17:17:44 UTC
Fixed in FOP Trunk.

see: http://svn.apache.org/viewvc?rev=433291&view=rev
Comment 6 Glenn Adams 2012-04-01 06:41:01 UTC
batch transition pre-FOP1.0 resolved+fixed bugs to closed+fixed