Bug 35854 - Apache 2.0.54 & Suexec
Summary: Apache 2.0.54 & Suexec
Status: CLOSED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_suexec (show other bugs)
Version: 2.0.54
Hardware: PC FreeBSD
: P1 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2005-07-25 20:52 UTC by Kurochkin Igor
Modified: 2005-07-27 01:47 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kurochkin Igor 2005-07-25 20:52:56 UTC
Hi. I have problem with Apache&suexec. 

When start Apache 
shows next message
"Warning: SuexecUserGroup directive requires SUEXEC wrapper." 
 

OS FreeBSD 4.11 
Apache 2.0.54 installed from source code:

CFLAGS="-O2 -funroll-loops -march=i686"; export CFLAGS 
"./configure" \ 
"--prefix=/usr/local" \ 
"--enable-layout=FreeBSD" \ 
"--with-perl" \ 
"--with-port=80" \ 
"--libdir=/usr/local/lib/apache2" \ 
"--includedir=/usr/local/include/apache2" \ 
"--enable-ssl" \ 
"--enable-so" \ 
"--enable-mods-shared=all" \ 
"--enable-suexec" \ 
"--with-suexec-docroot=/usr/local/www" \ 
"--with-suexec-userdir=virtual" \ 
"--with-suexec-logfile=/var/log/suexec.log" \ 
"--with-suexec-caller=www" \ 
"--with-suexec-bin=/usr/local/sbin" 

httpd.conf 

LoadModule suexec_module libexec/apache2/mod_suexec.so 
User www 
Group www 
<VirtualHost 192.168.0.254:80> 
    SuexecUserGroup user1 webusers 
    ServerAdmin igor@domain.ru 
    DocumentRoot /usr/local/www/virtual/site1 
    ServerName www.domain.ru 
    ErrorLog /var/log/domain-error.log 
    CustomLog /var/log/domain-access.log common 
    ScriptAlias /cgi-bin/ "/usr/local/www/virtual/site1/cgi-bin/" 
    AddType application/x-httpd-php .php .php3 
    Action application/x-httpd-php /cgi-bin/php 
    DirectoryIndex index.php index.shtml 
</VirtualHost> 

suexec -V 

-D AP_DOC_ROOT="/usr/local/www" 
-D AP_GID_MIN=100 
-D AP_HTTPD_USER="www" 
-D AP_LOG_EXEC="/var/log/suexec.log" 
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin" 
-D AP_UID_MIN=100 
-D AP_USERDIR_SUFFIX="virtual" 

user1 - uid>100. 
webusers - gid>100. 

/usr/local/sbin
-rwsr-xr-x  1 root wheel suexec 

File /var/log/suexec.log is empty.
Comment 1 André Malo 2005-07-26 11:42:52 UTC
Shouldn't it be --with-suexec-bin=/usr/local/sbin/suexec?
Comment 2 Kurochkin Igor 2005-07-27 09:12:38 UTC
(In reply to comment #1)
> Shouldn't it be --with-suexec-bin=/usr/local/sbin/suexec?
Many thanks. The problem is solved.