Bug 35864 - status worker doesn't list workers
status worker doesn't list workers
Status: RESOLVED FIXED
Product: Tomcat Connectors
Classification: Unclassified
Component: Common
unspecified
PC Windows XP
: P1 major (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 35924 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-07-26 12:45 UTC by Martin Goldhahn
Modified: 2008-10-05 03:09 UTC (History)
1 user (show)



Attachments
Patch that fixes the bug (1.84 KB, text/plain)
2005-07-26 12:48 UTC, Martin Goldhahn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Goldhahn 2005-07-26 12:45:48 UTC
The cause of problem is that the map that stores the worker properties is free'd
after being read. The values of properties, worker_env.worker_list stores just
pointers to the property map. After the property map is free'd the pointers are
invalid. This crashes if one tries to list the workers with the status worker.

Solutions: 1. copy the values (need proper allocation and freeing mem many places)
 2. keep the map during the whole lifetime of the ISAPI filter

The patch I attached uses the second solution.

I started with the first solution but this makes changes in many places necessary.
Comment 1 Martin Goldhahn 2005-07-26 12:48:12 UTC
Created attachment 15778 [details]
Patch that fixes the bug

patch for jakarta-tomcat-connectors\jk\native\iis\jk_isapi_plugin.c
see bug description
Comment 2 Martin Goldhahn 2005-07-26 12:59:27 UTC
This seems to be related to bug 35862
Comment 3 Mladen Turk 2005-09-12 16:11:40 UTC
*** Bug 35924 has been marked as a duplicate of this bug. ***
Comment 4 Mladen Turk 2005-09-12 16:12:26 UTC
Commited. Thanks!