Bug 36434 - Patch: Make JMX build time detection work with jdk 1.5
Summary: Patch: Make JMX build time detection work with jdk 1.5
Status: RESOLVED FIXED
Alias: None
Product: Log4j - Now in Jira
Classification: Unclassified
Component: Other (show other bugs)
Version: 1.2
Hardware: PC Linux
: P2 normal
Target Milestone: ---
Assignee: log4j-dev
URL: http://bugs.gentoo.org/show_bug.cgi?i...
Keywords: JDK1.5, PatchAvailable
Depends on:
Blocks:
 
Reported: 2005-08-31 10:10 UTC by Martin von Gagern
Modified: 2007-08-22 16:08 UTC (History)
1 user (show)



Attachments
log4j-1.2.11-java15 (2.39 KB, patch)
2005-08-31 10:11 UTC, Martin von Gagern
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin von Gagern 2005-08-31 10:10:31 UTC
The check for jmx in the build.xml does not work for jdk 1.5 since
javax.management.MBeanInfo is now included in the core API, but
com.sun.jdmk.comm.HtmlAdaptorServer is not. So I suggest to check for
HtmlAdaptorServer instead. I also suggest to set the source version to get rid
of some ant warnings. I will append a patch that does those two modifications.
There are still a lot of deprecation warnings, but I'm not sure if this is an
issue or not.
Comment 1 Martin von Gagern 2005-08-31 10:11:09 UTC
Created attachment 16261 [details]
log4j-1.2.11-java15
Comment 2 Kay Abendroth 2006-11-12 10:32:25 UTC
Does it still apply to version 1.2.14?

I think this is related/duplicate of #35831, which was fixed before release of
1.2.12.
Comment 3 Curt Arnold 2007-08-22 16:08:52 UTC
I believe this is fixed.