Bug 36684 - Misconfiguration on SSL could cause Apache2 Freeze
Summary: Misconfiguration on SSL could cause Apache2 Freeze
Status: RESOLVED DUPLICATE of bug 36286
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ssl (show other bugs)
Version: 2.0.54
Hardware: All Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-09-16 12:50 UTC by Francisco Gimeno
Modified: 2013-01-13 18:46 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Gimeno 2005-09-16 12:50:00 UTC
I have misconfigured a new VirtualHost with the following directive
SSLCertificateKeyFile
instead
SSLCertificateFile

When I did a reload, I got an error like this:
[Fri Sep 16 12:35:33 2005] [error] Server should be SSL-aware but has no
certificate configured [Hint: SSLCertificateFile]

And apache2 didn't answered anymore ( indeed I had to kill it ).

reload is supposed not to change behaviour on not changed config directives. IE:
I created a new VirtualHost with a wrong SSL directive. All the rest of
VirtualHosts failed when reload. 
Apache2ctl -t didn't found the error.

So, for production use this behaviour of breaking everything it's quite
dangerous ( indeed, it's better stopping the Apache or something ).
Comment 1 Joe Orton 2005-09-20 13:21:37 UTC
From your mention of an "apache2ctl", are you using a packaged version of httpd?

When you say:

> And apache2 didn't answered anymore ( indeed I had to kill it ).

what do you mean?  That there were httpd processes running but not responding to
requests?
Comment 2 Francisco Gimeno 2005-09-20 14:49:10 UTC
Yes... it doesn't accept TCP connections anymore.

well.. the test case it's really easy. Just configure a VirtualHost with SSLCertificateKeyFile and reload with 
apache2ctl.
Comment 3 Francisco Gimeno 2005-09-20 14:50:23 UTC
and about packaged version of Apache2, I'm using the Debian Sarge version  2.0.54(-5)
Comment 4 Joe Orton 2005-09-20 14:55:29 UTC

*** This bug has been marked as a duplicate of 36286 ***