Bug 36828 - mod_ssl fix 32699 makes apache return APR_ECONNRESET(104) as the HTTP error code
Summary: mod_ssl fix 32699 makes apache return APR_ECONNRESET(104) as the HTTP error code
Status: RESOLVED DUPLICATE of bug 31759
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: All (show other bugs)
Version: 2.0.54
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2005-09-27 19:20 UTC by Jason Brady
Modified: 2005-09-27 11:52 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason Brady 2005-09-27 19:20:14 UTC
Since the fix for bug #32699, I occasionally get 104 http error codes in my
access log. I have tracked it to aborted SSL connections. The patch for this bug
returns an APR_ECONNRESET which resolves to 104 on my linux system (Redhat 9 and
Fedora4). It shouldn't be returning invalid http error codes when trying to log
aborted http connections.

When I reported this on that bug, Joe Orton said that he thought this wasn't a
mod_ssl specific problem.

The same test as used in bug #32699 will cause the problem.
Comment 1 Joe Orton 2005-09-27 19:52:55 UTC
Thanks for filing the bug, Jason.  

I actually worked out what causes this yesterday; there is another bug already
filed for the issue.

*** This bug has been marked as a duplicate of 31759 ***