Bug 36893 - org.apache.jasper.JasperException: Can't find bundle for base name i18n, locale en_US
Summary: org.apache.jasper.JasperException: Can't find bundle for base name i18n, loca...
Status: RESOLVED INVALID
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Jasper (show other bugs)
Version: 5.0.0
Hardware: Other other
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2005-10-02 22:43 UTC by KDBeut
Modified: 2005-10-16 00:59 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KDBeut 2005-10-02 22:43:03 UTC
I try to access axis webapps after deploying it to Tomcat with JWSDP1.5 on 
Windows. 

Here's the detailed of my env:
CLASSPATH=.;C:\j2sdk1.4.2_05;C:\axis-1_2_1\lib\axis.jar;C:\axis-1_2_1
\lib\common-discovery-0.2.jar;C:\axis-1_2_1\lib\common-logging-
1.0.4.jar;C:\axis-1_2_1\lib\jaxrpc.jar;C:\axis-1_2_1\lib\saaj.jar;C:\axis-1_2_1
\lib\log4j-1.2.8.jar;C:\axis-1_2_1\lib\wsdl4j-1.5.1.jar;C:\axis-1_2_1\lib\axis-
ant.jar;C:\xerces-2_7_1\xml-apis.jar;C:\xerces-2_7_1\xercesImpl.jar

I follow Axis Installation Guide and try to access URL: 
http://localhost:8080/axis/; I first got a page showing the following 
information:
"
Apache-AXIS
We've moved to an internationalized top page. The new URL should be 
automatically loaded after 5 seconds.
If you want to visit the new site immediately, please click the above link. 
"

Then an error page came back with error code HTTP Status 500 - and detailed 
error message is as followed:


type Exception report

message 

description The server encountered an internal error () that prevented it from 
fulfilling this request.

exception 

org.apache.jasper.JasperException: Can't find bundle for base name i18n, 
locale en_US
	org.apache.jasper.servlet.JspServletWrapper.service
(JspServletWrapper.java:315)
	org.apache.jasper.servlet.JspServlet.serviceJspFile
(JspServlet.java:258)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:205)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:856)


root cause 

java.util.MissingResourceException: Can't find bundle for base name i18n, 
locale en_US
	java.util.ResourceBundle.throwMissingResourceException
(ResourceBundle.java:804)
	java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:694)
	java.util.ResourceBundle.getBundle(ResourceBundle.java:538)
	org.apache.jsp.axis.index_jsp.getRB(index_jsp.java:72)
	org.apache.jsp.axis.index_jsp.getMessage(index_jsp.java:168)
	org.apache.jsp.axis.index_jsp.getMessage(index_jsp.java:106)
	org.apache.jsp.axis.index_jsp.getLocaleChoice(index_jsp.java:82)
	org.apache.jsp.axis.index_jsp._jspService(index_jsp.java:312)
	org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:856)
	org.apache.jasper.servlet.JspServletWrapper.service
(JspServletWrapper.java:268)
	org.apache.jasper.servlet.JspServlet.serviceJspFile
(JspServlet.java:258)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:205)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:856)


note The full stack trace of the root cause is available in the Tomcat logs.


-------------------------------------------------------------------------------
-

Sun-Java-System/Web-Services-Pack-1.4

I'd appreciate if anyone can help me getting this resolved.

Thank you in advance for your time.
Comment 1 Yoav Shapira 2005-10-16 08:59:16 UTC
This appears to be a local configuration error or axis installation error. 
Please use the tomcat user mailing list (and/or the axis user one) to get help
debugging it.