Bug 37866 - NTEventLogAppender.dll not built, tested and placed in distribution
NTEventLogAppender.dll not built, tested and placed in distribution
Status: RESOLVED FIXED
Product: Log4j
Classification: Unclassified
Component: Appender
1.2
Other other
: P2 normal
: ---
Assigned To: log4j-dev
:
: 38203 38204 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2005-12-12 01:52 UTC by Curt Arnold
Modified: 2006-04-27 15:50 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Curt Arnold 2005-12-12 01:52:32 UTC
NTEventLogAppender.dll which provides access to the Win32 Event Log API methods
used by NTEveltLogAppender.java was built with a BAT file and required a
Microsoft compiler.  This enhancement adds a build.nt target to build.xml using
MinGW, adds a simple test to the test suite and adds the generated DLL to the
distribution.

The Microsoft Message Compiler (mc.exe) and MinGW need to be available on the
path.  The message compiler is available in the Platform SDK as well as Visual
Studio.
Comment 1 Curt Arnold 2005-12-12 02:10:47 UTC
Also added version info to the dll.
Comment 2 Curt Arnold 2006-01-27 20:12:00 UTC
In rev 372945 (trunk) and 372949 (branches/v1_2-branch) committed output of
Microsoft Message Compiler compilation of EventLogCategories.mc into
src/java/org/apache/log4j/nt which allows building NTEventLogAppender.dll
without having the Microsoft Platform SDK on the path, only MinGW is needed.

If changes need to be made to EventLogCategories.mc, to regenerate
EventLogCategories.rc, .h and MSG00001.bin, run "update.nt.msg" and commit changes.
Comment 3 Curt Arnold 2006-04-27 22:49:52 UTC
*** Bug 38203 has been marked as a duplicate of this bug. ***
Comment 4 Curt Arnold 2006-04-27 22:50:18 UTC
*** Bug 38204 has been marked as a duplicate of this bug. ***