Bug 37938 - 500 Internal Server Error error pages are being rendered in HTML markup
Summary: 500 Internal Server Error error pages are being rendered in HTML markup
Status: RESOLVED DUPLICATE of bug 39710
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.2.0
Hardware: Other Linux
: P2 normal with 1 vote (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: ErrorMessage
: 40652 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-16 19:48 UTC by Vincent Jong
Modified: 2006-12-08 10:47 UTC (History)
2 users (show)



Attachments
Screenshot of 500 Internal Server Error page being displayed as HTML markup (229.78 KB, image/jpeg)
2005-12-16 19:50 UTC, Vincent Jong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Jong 2005-12-16 19:48:45 UTC
Platform: x86
OS: RedHat 7.3

Did a fresh install of Apache 2.2.0 and when accessing a cgi script that, let's 
say doesn't have the correct permissions, a 500 error page is correctly 
generated. The problem is that this page is displayed as HTML mark up with the 
extra added line of:

Additionally, a 500 Internal Server Error
error was encountered while trying to use an ErrorDocument to handle the
request.

This behavior was confirmed by Joshua Slive from the users@httpd mailing list 
under the thread entitled "500 Internal Server Error pages being rendered as 
markup". Joshua then found something similar where a patch was issued from
http://issues.apache.org/bugzilla/show_bug.cgi?id=36090

I've applied the patch, reconfigured, recompiled, and reinstalled Apache 2.2.0 
and the problem still persists.

I've taken a screenshot of the displayed page, and although this screenshot is a 
more recent screenshot where I've added server tokens to httpd.conf, this would 
be seen even with a default httpd.config file.

Thanks,

Vincent J.
Comment 1 Vincent Jong 2005-12-16 19:50:30 UTC
Created attachment 17232 [details]
Screenshot of 500 Internal Server Error page being displayed as HTML markup
Comment 2 Paul Querna 2006-04-25 23:09:38 UTC
I can repo this on production machines.  At a guess I think we aren't merging
the error headers correctly.... It seems to only happen with CGIs.
Comment 3 Nick Kew 2006-04-25 23:29:25 UTC
Worth noting here: this could've been opened by the fix to PR#36090 
Comment 4 Clarence Donath 2006-09-25 20:27:19 UTC
I too am experiencing this.

SUSE LINUX 10.1 (i586)

Apache/2.2.3 (Unix) DAV/2 Server

Confirmed this problem when configured with default options.

Attempting to access http://localhost/cgi-bin/printenv results in the error, as
expected because CGI has not been enabled yet.

The error page is in HTML source... unrendered.

This is going to be a problem with my web developers.  It is not expected behavior.
Comment 5 Sven Strickroth 2006-10-01 17:34:00 UTC
*** Bug 40652 has been marked as a duplicate of this bug. ***
Comment 6 Vincent Jong 2006-12-08 10:47:22 UTC
Paul Querna has opened a bug that is the actual cause for this issue. Closing
this one as a duplicate of that bug.

*** This bug has been marked as a duplicate of 39710 ***