Bug 37944 - Unable to set cell style for the entire cell or in short to cell A:A or B:B
Summary: Unable to set cell style for the entire cell or in short to cell A:A or B:B
Status: RESOLVED WONTFIX
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: unspecified
Hardware: All All
: P1 enhancement (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 37945 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-17 00:17 UTC by Kumar
Modified: 2008-07-10 15:51 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kumar 2005-12-17 00:17:45 UTC
Hello,

I need to create a blank xls and set the cell styles to the whole column. 

Thanks
Kumar
Comment 1 Yegor Kozlov 2007-01-12 06:41:53 UTC
*** Bug 37945 has been marked as a duplicate of this bug. ***
Comment 2 Nick Burch 2008-07-10 15:51:57 UTC
Styling a whole column is not yet supported

For now, you should wait until all your data is in, then create the cell style for that column. Iterate over all rows, and style the cell in the required column for each row.