Bug 3807 - target .. access rights
Summary: target .. access rights
Status: RESOLVED DUPLICATE of bug 22020
Alias: None
Product: Ant
Classification: Unclassified
Component: Core (show other bugs)
Version: nightly
Hardware: Other other
: P3 enhancement (vote)
Target Milestone: ---
Assignee: Ant Notifications List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-09-25 02:41 UTC by Anders Kristian Andersen
Modified: 2008-02-22 12:18 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Kristian Andersen 2001-09-25 02:41:18 UTC
I suggest that targets can have access rights.
like

Access="public" -- (default) meaning that all can access the target.
Access="private" -- meaning that target can only be accessed from within the 
project.

Reasoning for suggestion:
By this it is possible to differentiate between internally tasks and externally 
tasks. It would become easier to make listings of commands from the commandline.

Best regards
Anders Kr. Andersen
Comment 1 Steve Loughran 2001-09-26 23:35:42 UTC
Anders,

You know that if you give a target a description tag it gets listed as 
a 'main' task other than a subproject. So for listing purposes, the solution 
is already pretty much implemented. 

Are there other needs of yours, such as the need to hide targets from external 
invocation?
Comment 2 Jan Mat 2003-09-05 14:52:48 UTC
This is the older bug. But on the other there is much more traffic, so I mark 
this bug as duplicate of 22020.

*** This bug has been marked as a duplicate of 22020 ***