Bug 38484 - webapps Admin: Invalid path /login was requested
Summary: webapps Admin: Invalid path /login was requested
Status: RESOLVED WONTFIX
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Administration (show other bugs)
Version: 5.5.17
Hardware: Other AIX
: P3 minor with 1 vote (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL: http://localhost:8080/admin/
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-01 21:27 UTC by Dieter Ludwig
Modified: 2009-05-24 16:59 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter Ludwig 2006-02-01 21:27:09 UTC
My Tomcat is 5.5.15 on AIX 5.1. I downloaded the seperate archive of the
admin-application (also 5.5.15) and unpacked it in the appropiate dirs
(admin.xml in conf/Catalina/localhost/, the rest in server/webapps).
When I point my browser to http://localhost:8080/admin/ I get the login
screen. Although everything seems correct, catalina.out reveals this:

ERROR org.apache.struts.action.RequestProcessor - Invalid path /login was requested
ERROR org.apache.struts.action.RequestProcessor - Invalid path /frameset was
requested

Then I can work without any problems in the admin-application. No extra errors
occures in the log
Comment 1 Dieter Ludwig 2006-02-17 14:53:02 UTC
Same failure occures also under Debian Sarge!!!
Comment 2 Emil Simeonov 2006-03-05 15:33:16 UTC
The same issue encountered with Tomcat 5.5.15, Slackware Linux 10.2, jdk: Sun SE
1.5_06.

The 'Admin' application cannot be reached at all. The installation of the admin
app was handled as described in the bug description.
Comment 3 Yoav Shapira 2006-04-14 19:09:48 UTC
You shouldn't unpack separately: the admin distro file contains the paths and
should be unpacked as one file.  I've just tried it on a clean 5.5.16
installation on FC5 (I don't have a Debian or Slackware box right now), works
fine.  
Comment 4 Dieter Ludwig 2006-04-25 16:44:19 UTC
I unpacked the admin-webapp in the new tomcat 5.5.16. Still the same failure:
the admin-webapp works fine, but there occures SEVERE-failures in catalina.out
when I login to the admin-webapp:
Apr 25, 2006 6:39:57 PM org.apache.struts.action.RequestProcessor processMapping
SEVERE: Invalid path /login was requested
Apr 25, 2006 6:40:02 PM org.apache.struts.action.RequestProcessor processMapping
SEVERE: Invalid path /frameset was requested
Regards, Didi
Comment 5 Doug Vegge 2006-04-27 17:54:38 UTC
The same error occurs with Tomcat 5.5.9.03 on HP-UX 11.11


Apr 27, 2006 9:29:36 AM org.apache.struts.action.RequestProcessor 
processMapping
SEVERE: Invalid path /login was requested
Comment 6 N. Flucke 2006-04-28 11:21:35 UTC
I got the same error on Solaris Sparc 5.9 with Tomcat 5.5.17.
The admin-app works fine, but when I login, I got the same two error messages.
Comment 7 Yoav Shapira 2006-12-26 17:00:33 UTC
Updating version to 5.5.17.
Comment 8 Yoav Shapira 2007-03-25 14:03:09 UTC
Still happen with 5.5.23?
Comment 9 Mark Thomas 2007-07-17 04:27:28 UTC
This is a side-effect of how we avoid loading the app on startup. It can be
ignored but it would be nice to suppress the messages.
Comment 10 Mark Thomas 2007-07-17 04:29:53 UTC
*** Bug 42913 has been marked as a duplicate of this bug. ***
Comment 11 Santosh 2007-07-30 08:32:16 UTC
(In reply to comment #8)
> Still happen with 5.5.23?
Yes, still its coming in 5.5.23.
Comment 12 malyadri 2008-01-10 01:34:07 UTC
Still happen with 5.5.25?
Comment 13 Mark Thomas 2009-05-24 16:59:04 UTC
The message is harmless and can be ignored. Given that the admin app discontinued after 5.5.x, I don't see the point in fixing this cosmetic issue.