Bug 38485 - connectionTimeout parameter ignored on HTTP Connector
connectionTimeout parameter ignored on HTTP Connector
Product: Tomcat 5
Classification: Unclassified
Component: Connector:HTTP
Other Linux
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
: 40401 (view as bug list)
Depends on:
  Show dependency tree
Reported: 2006-02-01 23:16 UTC by George Sexton
Modified: 2006-09-03 06:55 UTC (History)
1 user (show)


Note You need to log in before you can comment on or make changes to this bug.
Description George Sexton 2006-02-01 23:16:11 UTC
The HTTP Connector on 5.5.15 appears to ignore the connectionTimeout parameter.
Connection s timeout after 60 seconds, regardless of the configured setting.
Here's a sample configurtion:

<Server port="8005" shutdown="SHUTDOWN">
<Service name="Catalina">
<Connector port="8080" connectionTimeout="10000" />
<Engine name="Catalina" defaultHost="localhost">
<Host name="localhost" appBase="webapps">
<Valve className="org.apache.catalina.valves.AccessLogValve"
     prefix="localhost_access_log." suffix=".txt"
<Logger className="org.apache.catalina.logger.FileLogger"
        directory="logs"  prefix="localhost_log." suffix=".txt"

Running that configuration on a WinXP machine with JDK 1.5.0_06.

If I telnet to the machine, on the connector port, it times out after one minute.

gsexton@reddwarf> time telnet emp00 8080
Connected to emp00.
Escape character is '^]'.
Connection closed by foreign host.

real    1m0.568s
user    0m0.016s
sys     0m0.008s

I noticed this because I was looking at the manager application on my server,
and I noticed it was taking KeepAlive (State K) threads 60 seconds to revert to
Ready (R).
Comment 1 Remy Maucherat 2006-09-03 13:55:08 UTC
*** Bug 40401 has been marked as a duplicate of this bug. ***