Bug 38752 - error when running make
Summary: error when running make
Status: RESOLVED DUPLICATE of bug 38756
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.0.55
Hardware: Other AIX
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-22 16:52 UTC by moe2266
Modified: 2006-02-22 11:26 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description moe2266 2006-02-22 16:52:35 UTC
Hi;
i'm getting this error now when running "make" for version 2.0.49:

libtool: link: `user/unix/groupinfo.lo' is not a valid libtool object
make: 1254-004 The error code from the last command is 1.
Comment 1 William A. Rowe Jr. 2006-02-22 17:07:11 UTC
Please verify the behavior persists in the current release, which happens
to be 2.0.55

If so, you may wish to rerun ./buildconf with a locally installed, hacked
flavor of libtool supporting AIX's compile/link semantics.  But check first
that this wasn't already resolved.
Comment 2 moe2266 2006-02-22 17:40:03 UTC
yes, still the same with 2.0.55
Comment 3 Jeff Trawick 2006-02-22 18:56:03 UTC
What steps do you take to build after unpacking 2.0.55? What level of AIX is this?
Comment 4 William A. Rowe Jr. 2006-02-22 19:18:14 UTC
  Please don't open multiple bugs for a single issue.

*** This bug has been marked as a duplicate of 38756 ***
Comment 5 moe2266 2006-02-22 20:26:46 UTC
these are the steps:

get the tar file.
gunzip 
tar xvf tar_file
cd httpd-2.2.0

> ./configure --prefix=/opt/compitf/comp/vendor/Apache-2.2.0 --with-
mpm=worker --without-berkeley-db --enable-mods-shared=most --disable-threads --
with-module

make


this when i get the errors.
I'm using AIX 5.3 & the GCC version is below



moe@AIX# gcc -v
Reading specs from /opt/freeware/lib/gcc-lib/powerpc-ibm-aix5.3.0.0/3.3.2/specs
Configured with: ../configure --with-as=/usr/bin/as --with-ld=/usr/bin/ld --
disable-nls --enable-languages=c,c++ --prefix=/opt/freeware --enable-threads --
enable-version-specific-runtime-libs --host=powerpc-ibm-aix5.3.0.0
Thread model: aix
gcc version 3.3.2