Bug 38831 - Lines are appearing without arrows when rasterizing an SVG generated by Visio-2003
Summary: Lines are appearing without arrows when rasterizing an SVG generated by Visio...
Status: RESOLVED INVALID
Alias: None
Product: Batik - Now in Jira
Classification: Unclassified
Component: SVG Rasterizer (show other bugs)
Version: 1.6
Hardware: PC Windows 2000
: P2 major
Target Milestone: ---
Assignee: Batik Developer's Mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-02 16:12 UTC by Sasha G
Modified: 2006-03-04 19:18 UTC (History)
0 users



Attachments
The SVG file created by Visio 2003 (1.71 KB, text/xml)
2006-03-02 16:13 UTC, Sasha G
Details
The original Visio file (12.00 KB, application/vnd.visio)
2006-03-02 16:13 UTC, Sasha G
Details
The png file rasterized by Batik (3.61 KB, image/png)
2006-03-02 16:13 UTC, Sasha G
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sasha G 2006-03-02 16:12:23 UTC
Visio 2003 supports export to SVG. Generally rasterization of those files works
okay, but if a line with an arrow ending is used in Visio, the rasterized file
doesn't have the arrow - only the line itself.

To reproduce:
1. Open a new file in Visio2003
2. Create a simple line.
3. Go to 'Format --> Line' and set an arrow ending for the line
4. 'Save as' SVG file
5. Rasterize the file to jpg
6. See that the jpg file has only the line, without the arrow
Comment 1 Sasha G 2006-03-02 16:13:05 UTC
Created attachment 17818 [details]
The SVG file created by Visio 2003
Comment 2 Sasha G 2006-03-02 16:13:25 UTC
Created attachment 17819 [details]
The original Visio file
Comment 3 Sasha G 2006-03-02 16:13:53 UTC
Created attachment 17820 [details]
The png file rasterized by Batik
Comment 4 Sasha G 2006-03-02 16:16:26 UTC
(In reply to comment #0)
> Visio 2003 supports export to SVG. Generally rasterization of those files works
> okay, but if a line with an arrow ending is used in Visio, the rasterized file
> doesn't have the arrow - only the line itself.
> 
> To reproduce:
> 1. Open a new file in Visio2003
> 2. Create a simple line.
> 3. Go to 'Format --> Line' and set an arrow ending for the line
> 4. 'Save as' SVG file
> 5. Rasterize the file to jpg
> 6. See that the jpg file has only the line, without the arrow

Correction for 5-6: SVG was rasterized to PNG file and not JPG
Comment 5 Thomas Deweese 2006-03-05 04:18:36 UTC
The output of Viso is in error.
The marker element does not take into account clipping due to
the marker establishing a new viewport.

There are two potential fixes for the viso output:
   1) add 'overflow="visible"' to the marker element.
   2) Add an appropriate viewBox and markerWidth/Height attribute:
       markerWidth="15" markerHeight="15" viewBox="-15.5 -6 16 6"