Bug 38994 - ap_graceful_stop_signalled() always returns "0" from prefork.c
Summary: ap_graceful_stop_signalled() always returns "0" from prefork.c
Status: RESOLVED DUPLICATE of bug 41743
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mpm_prefork (show other bugs)
Version: 2.0.55
Hardware: Other other
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-16 02:19 UTC by Anton Lavrentiev
Modified: 2011-02-15 22:31 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Lavrentiev 2006-03-16 02:19:14 UTC
mpm/prefork/prefork.c implements ap_graceful_stop_signalled() as
the following (BTW, same goes true for mpm/netware/mpm_netware.c but
I don't use that at all):

    int ap_graceful_stop_signalled(void)
    {
        /* not ever called anymore... */
        return 0;
    }
 
Not only the comment is wrong (the function IS actually called from
modules/core/http_core.c), this "implemetation" goes out of
sync with implementations of the same call in all other MPMs, so
any code that depends on whether the restart is graceful or
forced, will fail to detect this, yet the fix is the simplest ever:
just a return of "is_graceful" instead of plain "0" will do the job.
Comment 1 Andrew 2011-02-01 21:23:18 UTC
This bug is related to bug 41743 - which has a candidate patch available.
Comment 2 Andrew 2011-02-15 22:31:04 UTC

*** This bug has been marked as a duplicate of bug 41743 ***