Bug 39228 - wrong order of slides in slideShow
Summary: wrong order of slides in slideShow
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSLF (show other bugs)
Version: unspecified
Hardware: Other Windows XP
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 39229 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-06 20:23 UTC by karajo
Modified: 2006-06-27 11:15 UTC (History)
0 users



Attachments
Example of wrong order of slides (9.50 KB, application/vnd.ms-powerpoint)
2006-04-07 16:20 UTC, karajo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karajo 2006-04-06 20:23:22 UTC
The order of slides is wrong when using slideShow.getSlides();.
also, the slide.getSlideNumber is corresponds to the order of the lides array,
but does not correspond to the real order of slides
I read in the mailing lists that other people encountered the same 
problem too, and that there were some fixes for that also. But I'm 
still getting it wrong...
Comment 1 Nick Burch 2006-04-07 11:01:41 UTC
Could you please upload a test file that shows this behavoir?

(All the current test files do have their slides returned in the right order, so
we'll need something where it breaks to be able to figure it out from)
Comment 2 karajo 2006-04-07 16:20:36 UTC
Created attachment 18039 [details]
Example of wrong order of slides
Comment 3 karajo 2006-04-07 16:21:31 UTC
I found the problem - the slides are ordered by the order in which they were
created, meaning if you added the first slide last, it will appear as the last
slide in the Slide.getSlides() array.
Attached is a sample ppt file.
Comment 4 karajo 2006-04-08 11:06:19 UTC
*** Bug 39229 has been marked as a duplicate of this bug. ***
Comment 5 Nick Burch 2006-04-12 19:05:35 UTC
I've added this file to the test set, so we have something to work with.

However, since it now looks like PowerPoint doesn't do an internal slide ID
renumber when you swap the position of two slides, things are going to be a bit
trickier.

We'll need to find where PowerPoint stores what order it thinks the slides
should be displayed in, before we can return the slides in the correct ordering
ourselves.
Comment 6 Nick Burch 2006-06-27 18:15:05 UTC
I think this has now been fixed. (I have a testcase for your problem file that
now passes)

Could you give a svn checkout a try on your more complex files?