Bug 39476 - Improve build.xml file
Improve build.xml file
Product: Tomcat 5
Classification: Unclassified
Component: Unknown
All All
: P2 enhancement (vote)
: ---
Assigned To: Tomcat Developers Mailing List
Depends on:
  Show dependency tree
Reported: 2006-05-03 19:05 UTC by Gregory S. Hoerner Sr.
Modified: 2006-12-24 19:31 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Gregory S. Hoerner Sr. 2006-05-03 19:05:17 UTC
The build.xml file which ships with both TomCat 5.5.16 and 5.5.17 (source
package) is missing the following:

<?xml version="1.0"?>

from the first line of the file. I installed the package fine on Fedora Core 4
(Stock install), but apparently the XML handling on Fedora Core 5 is much
stricter and leads to a NullPointerException as a result. This file needs to be
updated to include this line.

I used the same Java SDK on both.
Comment 1 Mark Thomas 2006-07-08 21:52:06 UTC
The xml specification recommends this but does not mandate it. build.xml is
compliant with the xml spec without this text. The root cuase of this issue is
the overly strict xml validation on your system.

I am therefore changing this to an enhancement request and have changed the
title to since build.xml is not invalid.
Comment 2 Yoav Shapira 2006-12-24 19:31:34 UTC
I agree with Mark's opinions, and I think this is a worthy enhancement, so I've
gone ahead and added the XML declaration to the main build.xml file and a couple
of other intermediate build.xml files as well.  Thanks for reporting this.