Bug 39524 - FIBFieldHandler fails if it runs out of data
Summary: FIBFieldHandler fails if it runs out of data
Status: RESOLVED LATER
Alias: None
Product: POI
Classification: Unclassified
Component: HWPF (show other bugs)
Version: 3.0-dev
Hardware: Other other
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-09 05:17 UTC by Trejkaz (pen name)
Modified: 2008-04-28 18:22 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Trejkaz (pen name) 2006-05-09 05:17:37 UTC
If FIBFieldHandler runs out of the table stream before it finishes reading,
unexpected things occur.

For instance, the constructor for UnhandledDataStructure will throw an
ArrayIndexOutOfBoundsException if it tries to read more than the length.  This
should be prevented by not instantiating structures if you know they require
more data than is available.
Comment 1 Trejkaz (pen name) 2006-05-09 05:25:34 UTC

*** This bug has been marked as a duplicate of 10335 ***
Comment 2 Trejkaz (pen name) 2008-04-27 20:07:51 UTC
...what the hell did I do back then?  Whatever I did, clearly the bug I marked it as a duplicate of is unrelated.

Comment 3 Nick Burch 2008-04-28 04:08:35 UTC
Any chance you could upload a problem file for this? A patch too would be great if you happen to have knocked one up :)
Comment 4 Trejkaz (pen name) 2008-04-28 18:22:53 UTC
I haven't created a patch yet, no... and I don't seem to be able to find a file which exhibits the problem.  The bug on our end was raised by someone else and they didn't put a file on the bug either.

Maybe we can close it for now then... I'll go with that and can always reopen it if we find the problem again.