Bug 39578 - Compatibility to JSR 170 : Content Repository for the Java technology API
Summary: Compatibility to JSR 170 : Content Repository for the Java technology API
Status: RESOLVED WONTFIX
Alias: None
Product: Lenya
Classification: Unclassified
Component: Repository Integration (show other bugs)
Version: Trunk
Hardware: All other
: P2 enhancement
Target Milestone: 2.0.1
Assignee: Lenya Developers
URL:
Keywords: RFC
Depends on:
Blocks:
 
Reported: 2006-05-14 11:23 UTC by T. Giesecke
Modified: 2010-07-10 05:26 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description T. Giesecke 2006-05-14 11:23:43 UTC
Today, many content management systems using propietary repositories and
propietary APIs for repository access.
 
The JSR 170 defines a Content Repository for the Java technology API.
The main goal is the compatibility/interoperability between different content
repositories and a standard API to access repositories.

http://www.jcp.org/en/jsr/detail?id=170
http://jcr.day.com/

Another interesting JSR in this context:
http://www.jcp.org/jsr/detail/147.jsp (Workspace Versioning and Configuration
Management)
Comment 1 Andreas Hartmann 2006-05-15 07:25:52 UTC
With "compatibility", do you mean that a Lenya content repository should be
accessible using the JSR 170 API? Or do you mean that Lenya should be able to
access JSR 170 repositories?
Comment 2 T. Giesecke 2006-05-20 12:51:17 UTC
Both. This (the interoperability between repositories; not CMS) is one of the
main targets of JSR 170. Lenya should handle JSR170 compatible repositories, not
"a" Lenya repository.
Comment 3 Andreas Hartmann 2006-05-22 08:10:07 UTC
That's a tempting idea, but also an extremely ambitious one. IMO a generic JCR
approach would increase the complexity of the codebase beyond maintainability.
It would require a configurable layer to map the semantics of the CMS to the
syntax of the JCR repository.
Comment 4 Richard Frovarp 2010-07-10 05:26:57 UTC
JCR integration is a goal for the next version of Lenya. Modification of Lenya 2.x to have proper support for JCR will not happen at this time. Thank you for your submission.