Bug 39645 - proxy error: Error reading from remote server
Summary: proxy error: Error reading from remote server
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy (show other bugs)
Version: 2.0.55
Hardware: Sun Solaris
: P2 critical (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-23 17:58 UTC by J Srinivasa Rao
Modified: 2006-06-14 05:33 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description J Srinivasa Rao 2006-05-23 17:58:03 UTC
I configured the Apache httpd-2.0.55 as Reverse proxy server for a JBOSS backend
application server. 

It seems everything working fine. But some times ( intermittently) i am seeing
an following error. 

Proxy Error: The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request POST /jsp/file/file_upload1.jsp.
Reason: Error reading from remote server

The folllwing are the errors found in the error_logs

[Tue May 23 05:30:24 2006] [error] [client 10.10.7.69] proxy: error reading
status line from remote server myserver, referer: http:/
/myserver.mydomain.com/jsp/authapp/group_app_add1.jsp
[Tue May 23 05:30:24 2006] [error] [client 10.10.7.69] proxy: Error reading from
remote server returned by /jsp/authapp/group_app_ad
d1.jsp, referer: http://proxy.mydomain.com/jsp/authapp/group_app_add1.jsp
Comment 1 Ruediger Pluem 2006-05-23 18:28:51 UTC
Are you using SSL on httpd side? If you yes, you have been hit by PR37145.
Comment 2 J Srinivasa Rao 2006-05-23 18:35:32 UTC
(In reply to comment #1)
> Are you using SSL on httpd side? If you yes, you have been hit by PR37145.

Yes I am using ssl on httpd side. But i am seeing this error on both http( Non
SSL ) and https:// ( SSL ) requests intermittently 


Comment 3 J Srinivasa Rao 2006-05-23 18:44:58 UTC
The patch PR37145 has been applied earlier before moving Reverse proxy server to
production. 



Comment 4 Ruediger Pluem 2006-05-23 19:17:17 UTC
Either there is a problem with your backend system or you are probably facing
some sort of keepalive problem (backend closed connection just as httpd sent
request).
I know that this may not be possible in a production environment, but are you
able to catch such a situation with a network sniffer?

Another approach would be to disable keepalives to the backend to find out if
this makes the problem go away. So please try the following setting:

SetEnv proxy-nokeepalive 1
Comment 5 Marco Berizzi 2006-06-14 10:38:22 UTC
I'm having a similar problem with apache 2.2.2 and IIS from windows
2003sp1/2000sp4/nt40sp6a (no ssl & only ipv4).
'SetEnv proxy-nokeepalive 1' resolves the problem. The problem is related to a
RST packet sent from the backend server to the apache reverse proxy.
See http://issues.apache.org/bugzilla/show_bug.cgi?id=39499#c7

apache is running on linux 2.6.16.20 and/or 2.6.17-rc6
Comment 6 J Srinivasa Rao 2006-06-14 12:33:18 UTC
Hi Guys 

  First of all, thanks alot for all your sugestions. 
  
  I tried with this "SetEnv proxy-nokeepalive 1" setting last week. and my QA
team monitored the system for a week. seems to be everything is good and the
problem is fixed. 

Thanks once gain ..