Bug 39679 - ab truncates post data if data is specified in a file
Summary: ab truncates post data if data is specified in a file
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: support (show other bugs)
Version: 2.5-HEAD
Hardware: Other other
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2006-05-30 06:03 UTC by Davanum Srinivas
Modified: 2008-05-27 15:15 UTC (History)
0 users



Attachments
patch for preventing truncation of a large request (546 bytes, patch)
2006-05-30 06:08 UTC, Davanum Srinivas
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Davanum Srinivas 2006-05-30 06:03:43 UTC
If i try to specify post data in a file and the file is rather big then ab does
not send the whole contents of the file.

ab -p echoStrings-10000.txt -k -H 'SOAPAction: echoStrings' -T text/xml -t
999999 -k -c 5 -n 50 http://192.168.1.107:9762/axis2/services/Benchmark
Comment 1 Davanum Srinivas 2006-05-30 06:08:24 UTC
Created attachment 18369 [details]
patch for preventing truncation of a large request

#1: if the return value from apr_socket_send is say 11 code just return from
the write_request method, irrespective of APR_STATUS_IS_EAGAIN is true or
false. Move the return statement to just after close_connection so that we try
to send the rest of the data
#2: if there is nothing to send, then break from the loop.
Comment 2 Davanum Srinivas 2006-05-30 15:50:22 UTC
Looks related to bug 10038
Comment 3 Roy T. Fielding 2008-05-12 13:55:47 UTC
Fixed in trunk (r655637).
Duplicate of bug 10038.
Comment 4 Ruediger Pluem 2008-05-27 15:15:31 UTC
Backported to 2.2.x as r660576 (http://svn.apache.org/viewvc?rev=660576&view=rev).