Bug 39791 - very poor default for "Use Naming" when creating new Context
very poor default for "Use Naming" when creating new Context
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Administration
5.0.28
PC Windows Server 2003
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-06-12 19:00 UTC by Clay Embry
Modified: 2006-06-12 16:03 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Clay Embry 2006-06-12 19:00:37 UTC
When creating a new Context using the Administration webapp, the property
useNaming ("Use Naming" in the HTML form for creating a new context) defaults to
"false". That seems like a poor choice for the default given that it means that
if you create a new Context and a new DataSource using the Admin webapp and you
just accept all the defaults, you will not be able to use the DataSource in your
new Context. Also, the Context Container section in the Server Configuration
Reference says that the default value of the property should be "true".

Symptom:
If you create a Context and DataSource using the Admin webapp and try to use the
DataSource as explained in the How To guide, you will get this exception:
"javax.naming.NameNotFoundException: Name java:comp is not bound in this Context"
Googling seems to show a lot of people having this problem. Not sure how often
it was caused by this issue. It can easily trip up a newbie like me.

To Reproduce:
Create a new Context using the Admin webapp. Do not change any of the default
values for properties. Create a new DataSource in the Context using the Admin
webapp and try to use it in the new Context using code from the How To guide.
Comment 1 Mark Thomas 2006-06-12 23:03:53 UTC
Fixed in SVN. Will be in 5.5.18+