Bug 39942 - Suggestion...add HSSF object factory
Summary: Suggestion...add HSSF object factory
Status: RESOLVED LATER
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.5-FINAL
Hardware: Other other
: P4 enhancement (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 39943 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-07-01 16:59 UTC by Dan P
Modified: 2015-05-01 20:58 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan P 2006-07-01 16:59:16 UTC
Create a POI object factory that would, at a minimum, create cell style and 
font objects based on a configuration file (xml or ini).  This would serve 
three purposes: 1) it would act like an html style sheet and allow you to 
centralize look and feel, 2) would allow for external customization of HSSF 
objects without a recompile, and 3) would remove 5 to 10 lines of code per 
object.  The configuration file could be divided into namespaces (ala log4j), 
allowing for the configuration to be hierarchical (meaning shared objects 
would only have to be defined once).  For example:

   IHSSFObjectFactory factory = HSSFObjectFactory.createFactory("namespace");
   HSSFFont headerFont = factory.createFont("header-font");

I have some sample code, but I'm not sure how I proceed from here.
Comment 1 Yegor Kozlov 2007-01-12 03:00:26 UTC
*** Bug 39943 has been marked as a duplicate of this bug. ***
Comment 2 Dominik Stadler 2015-05-01 20:58:35 UTC
No update on this one for a very long time, thus I am closing this as LATER. Please discuss on the dev mailing list if you plan to work on this.