Bug 40130 - Included files not found in Tomcat 5.5.17
Summary: Included files not found in Tomcat 5.5.17
Status: RESOLVED DUPLICATE of bug 39817
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Jasper (show other bugs)
Version: 5.5.17
Hardware: Other Windows 2000
: P2 major (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-27 21:01 UTC by Eric Sandusky
Modified: 2006-07-27 14:07 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Sandusky 2006-07-27 21:01:15 UTC
Upon upgrading from Tomcat 5.5.9 to 5.5.17 (fresh install on 2 machines), 
using similar setup (changes to server.xml only), certain jsps on my site are 
not found when they are included within another jsp.

My question is, has something changed in the configuration of Tomcat?  Why 
would some includes work and others not?  My code looks like this..

<%@ include file="/catalog/header.jsp" %>

The Exception is..

SEVERE: Servlet.service() for servlet jsp threw exception
org.apache.jasper.JasperException: /index.jsp(12,0) File "/catalog/header.jsp" 
not found

d:/webapps/concept700dev/catalog/index.jsp exists
d:/webapps/concept700dev/catalog/header.jsp exists

My server.xml setup is..

     <Host name="concept700dev.configureone.net" debug="0" 
appBase="d:/webapps/concept700dev" unpackWARs="true" autoDeploy="true">
	<Context path="" docBase="" reloadable="true" debug="0" 
workDir="work\Catalina\concept700dev.configureone.net">
	</Context>
	<Manager className="org.apache.catalina.session.PersistentManager" 
saveOnRestart="true"/>
     </Host>
Comment 1 Mark Thomas 2006-07-27 21:07:26 UTC

*** This bug has been marked as a duplicate of 39817 ***