Bug 40424 - Web Services proxy
Summary: Web Services proxy
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.2
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords: PatchAvailable
: 31920 (view as bug list)
Depends on: 52674
Blocks:
  Show dependency tree
 
Reported: 2006-09-06 11:39 UTC by Benoit LAVENIER
Modified: 2013-02-09 21:18 UTC (History)
2 users (show)



Attachments
JAR file (with sources) for enable web services proxy (62.20 KB, application/octet-stream)
2006-09-06 11:43 UTC, Benoit LAVENIER
Details
ApacheJMeter_wsproxy_0.2.jar (40.17 KB, application/octet-stream)
2006-09-14 09:27 UTC, Benoit LAVENIER
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Benoit LAVENIER 2006-09-06 11:39:50 UTC
Why not create a Web Services proxy ? I mean a proxy that create Web Services
Samplers.

I did it from http proxy sucessfully class.

You maybe will need to check the code, because i had some hack code 

The attached JAR file with binary AND source
Comment 1 Benoit LAVENIER 2006-09-06 11:43:01 UTC
Created attachment 18826 [details]
JAR file (with sources) for enable web services proxy

put the jar in your <JMETER_HOME>/lib/ext direcoty
Then add the following line in <JMETER_HOME>/bin/jmeter.properties file :
    search_paths=../lib/ext/ApacheJMeter_wsproxy.jar
Comment 2 Sebb 2006-09-06 12:32:23 UTC
Thanks!

BTW, there should be no need to update search_paths if the jar is in the 
lib/ext directory.
Comment 3 peter lin 2006-09-13 18:01:30 UTC
*** Bug 31920 has been marked as a duplicate of this bug. ***
Comment 4 Benoit LAVENIER 2006-09-14 09:27:48 UTC
Created attachment 18862 [details]
ApacheJMeter_wsproxy_0.2.jar
Comment 5 Benoit LAVENIER 2006-09-14 09:31:02 UTC
I posted a new version od the proxy : 
- Now the Proxy record not only WebServices (SOAP) request, but also HTTP request.
- In addition, you could configure a redirection (host and port) of all requests
Comment 6 Sebb 2007-02-27 15:33:39 UTC
What is the purpose of the HttpReplyHdr class?
It seems to be the same as the existing one in http/proxy.

Likewise, what is the purpose of the wsproxy/WebServiceSampler class? 
It redefines convertSoapHeaders and changes the key/value separator from "=" 
to ": " and adds some extra information to the sampleResult. The new class 
won't be used by existing test plans. If the changes are worthwhile, then they 
should be added to the existing class.

What is the purpose of the host/port redirection?
Comment 7 Benoit LAVENIER 2007-02-28 02:42:44 UTC
Hi Sebb !
- The HttpReplyHdr class has no changes.
- i agree with you : the wsproxy/WebServiceSampler should not exists anymore. I
didn't wanted to change existing classes at all, that's why i made a lot of code
duplication. In addition, i had few time to develop the WSProxy, so you should
examine in details all my code.
- host/port redirection should help to redirect the SOAP request without setting
up a proxy in the WebService client. My client soft (soft under test) don't
support proxy redirection, that's why i add redirection capability.

I have found two majors bugs in the WSProxy : 
- bad data encoding (i.e. specials caracters in ISO-8859-15 are converted into '?')
- binaries datas are not supported very well (i.e. jpg).

Thanks !(In reply to comment #6)
> What is the purpose of the HttpReplyHdr class?
> It seems to be the same as the existing one in http/proxy.
> 
> Likewise, what is the purpose of the wsproxy/WebServiceSampler class? 
> It redefines convertSoapHeaders and changes the key/value separator from "=" 
> to ": " and adds some extra information to the sampleResult. The new class 
> won't be used by existing test plans. If the changes are worthwhile, then they 
> should be added to the existing class.
> 
> What is the purpose of the host/port redirection?
Comment 8 Philippe Mouawad 2012-03-11 18:42:17 UTC
This feature CAN be implémented with less code after enhancement 52674, shall se do it ?
Comment 9 Philippe Mouawad 2013-02-09 21:18:30 UTC
Fixed as part of 53840