Bug 40499 - Need to be able to simulate abortive connection release in JMeter
Summary: Need to be able to simulate abortive connection release in JMeter
Status: RESOLVED DUPLICATE of bug 54230
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.2
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-13 15:45 UTC by Neil Ferguson
Modified: 2012-12-20 22:33 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Neil Ferguson 2006-09-13 15:45:28 UTC
It would be useful to perform abortive connection release (i.e. sending a TCP
RST instead of FIN) in JMeter. This is useful to prevent large numbers of
sockets sitting around with a TIME_WAIT status. OpenSTA has a feature that
allows this (in TestExecutor_web.ini under the [Sockets] section, the Linger
property can be set to 0).

Java (well, the Sun JVM anyway, I'm not sure about others) allows us to perform
an abortive connection release by setting socket lingering to on, and the socket
linger time to 0 (using the Socket.setSoLinger method -- see
http://java.sun.com/j2se/1.5.0/docs/guide/net/articles/connection_release.html).

The Jakarta Commons HTTP Client allows the socket linger time to be set to 0
(using the http.socket.linger property) so this should be a relatively easy fix.
However there appears to be a bug that prevents socket lingering from being
turned-on when the linger time is set to 0 (I've raised this, see:
https://issues.apache.org/jira/browse/HTTPCLIENT-599).
Comment 1 Philippe Mouawad 2011-11-14 12:14:09 UTC
Still not implemented in 2.5.1
Comment 2 Philippe Mouawad 2012-12-20 22:33:35 UTC

*** This bug has been marked as a duplicate of bug 54230 ***