Bug 40679 - PermGen Space OutOfMemory Error after repeated Reload
Summary: PermGen Space OutOfMemory Error after repeated Reload
Status: RESOLVED DUPLICATE of bug 39090
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 5.5.9
Hardware: PC Windows 2000
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL: http://www.netbeans.org/issues/show_b...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-04 09:25 UTC by Rich Unger
Modified: 2006-11-19 19:39 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rich Unger 2006-10-04 09:25:02 UTC
Using Tomcat's Manager user interface I repeatedly
redployed (the button is labeled "Reload" in the Tomcat Manager UI) a simple web
application and I saw perm gen increase in size (by about 8K) each time.  When
the web application has more classes, the increase is more rapid.
Comment 1 Rich Unger 2006-10-04 09:25:42 UTC
See http://www.netbeans.org/issues/show_bug.cgi?id=86407 for more details.
Comment 2 Chris Halstead 2006-10-05 11:11:01 UTC
It's unclear from the description and linked netbeans bug report whether you are
seeing this issue only when running within netbeans.  Have you confirmed this
behaviour running tomcat outside of netbeans?
Comment 3 Rich Unger 2006-10-05 11:33:04 UTC
Sorry, I paraphrased in the initial description.  The NetBeans bug report does
specifically state, however:
"Using Tomcat's Manager user interface (instead of NetBeans) I repeatedly
redployed (the button is labeled "Reload" in the Tomcat Manager UI) a simple web
application and I saw perm gen increase in size (by about 8K) each time."
Comment 4 Filip Hanik 2006-10-06 15:18:03 UTC
There are known issues around reloading of the apps, some are related to Threads
and ThreadLocal references.
Do you have a test case, we'd love to get our hands on it.
Comment 5 Rich Unger 2006-10-06 15:25:11 UTC
This was just the default webapp template in the NetBeans 5.0 IDE.  You can
create a new web application in NB, and build a .war file from it and use that.
 That will give you a webapp that grows by 8k per reload.

Just by going to the "libraries" customizer for the project, and adding the
"JSF" library from the default list of libraries, you can make each reload
increase your PermGen space usage by over a megabyte.
Comment 6 Mark Thomas 2006-11-19 19:39:27 UTC
Having downloaded NetBeans 5.0 and tested with the default web application I
cannot re-create this issue. I am guessing the root cause is the same as bug
39090 which is fixed in 5.5.16 onwards. I am therefore resolving it as a duplicate.

*** This bug has been marked as a duplicate of 39090 ***