Bug 40692 - unable to use the file browser to open a jmx file.
Summary: unable to use the file browser to open a jmx file.
Status: RESOLVED INVALID
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.2
Hardware: PC Windows XP
: P3 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords: RFC
Depends on:
Blocks:
 
Reported: 2006-10-05 19:00 UTC by san
Modified: 2020-03-17 09:45 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description san 2006-10-05 19:00:44 UTC
jmeter hangs up when i try to use the gui to open a .jmx file for testing. but
when i try the same specifying the -t switch followed by then jmx file, then
jmeter opens up displaying the test file. but if i use the gui to open a file it
jus hangs up. i found a way to use the gui to open up the file. i go to
options->look and feel->CDE/Motif n then try to open a file using the file
browser then jmeter allows a jmx file to be opened. after i open the jmx file i
go back and change the look n feel to windows or metal then the file browser
continues to function but in CDE/Motif. currently i m jus creating .bat files
with -t switches as a workaround.


******************************************************************************
2006/10/06 11:48:18 WARN  - jmeter.gui.util.MenuFactory: Missing jar? Could not
create org.apache.jmeter.visualizers.MailerVisualizer.
java.lang.NoClassDefFoundError: javax/mail/MessagingException 
2006/10/06 11:48:18 INFO  - jmeter.samplers.SampleResult: Note: Sample
TimeStamps are START times 
2006/10/06 11:48:18 INFO  - jmeter.samplers.SampleResult:
sampleresult.default.encoding is set to ISO-8859-1
Comment 1 Sebb 2006-10-06 06:10:39 UTC
Does this happen with all JMX files?

Any messages in jmeter.log or in the DOS console when it hangs?

[By the way, you can drop a JMX file on jmeter-t.bat and it will open the 
file.]
Comment 2 Sebb 2006-11-27 14:49:09 UTC
Cannot reproduce this.