Bug 40693 - mod_deflate, mod_include and mod_fcgid does not work together
Summary: mod_deflate, mod_include and mod_fcgid does not work together
Status: RESOLVED DUPLICATE of bug 17629
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: All (show other bugs)
Version: 2.2-HEAD
Hardware: Other Linux
: P1 major (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-06 02:22 UTC by Stefan Priebe
Modified: 2006-10-06 03:43 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Priebe 2006-10-06 02:22:20 UTC
Hello!

I'm not sure where the bug is. But is is really funny. I'm using httpd-2.2.3 
and mod_deflate, mod_include and mod_fcgid.

My Filter settings are:
AddType text/html .shtml .shtm
AddOutputFilter INCLUDES .shtm .shtml
AddOutputFilterByType DEFLATE application/xhtml+xml text/html text/plain 
text/css text/xml

Now i've an .shtml page with

TEXT 1

<!--#include virtual="myscript.php">

TEXT 2

The content i get if i do a request to my .shtml page looks like:

OUTPUT of the PHP SCRIPT in plain text
DEFLATE COMPRESSED TEXT

That can't be right...

Stefan
Comment 1 Nick Kew 2006-10-06 03:43:10 UTC
This looks like bug 17629.  If it's something different, please describe it 
with sufficient detail to give us a clue what's going on.

*** This bug has been marked as a duplicate of 17629 ***