Bug 40757 - Web Service(SOAP) Request Response Time
Summary: Web Service(SOAP) Request Response Time
Status: RESOLVED WONTFIX
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.2
Hardware: PC Windows XP
: P2 major with 2 votes (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-13 13:48 UTC by Fei Wang
Modified: 2013-09-09 07:47 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fei Wang 2006-10-13 13:48:51 UTC
I was doing load testing against XFire and AXIS (deployed on JBoss 4.0.1SP1). 
I used both JMeter and SOAPUI to measure response time, but the result is quite
different. SOAPUI says it takes about 10ms, while JMeter think it takes 200ms. 
I checked the reponse, both SOAPUI and JMeter did get the right response back.

Finally, I got wireshark and captured the packets on wire. And here is what I
observed: when using JMETER, The HTTP request was segmented into two packets.
There was a significant delay (about 200ms) between the first segment and the
ACK. After the server got 2nd packet, it only took 5 ms to send a response back.

After some research, I realize that JMeter is using Apache SOAP, which seems
handle HTTP request by itself instead of using commons-httpclient. I am guessing
 the improper HTTP handling in Apache SOAP is the root cause. I know Apache SOAP
is not supported anymore and you are planning to move to another SOAP stack. So
hopefully my observation give you another reason to move since the whole Web
Service(SOAP) sampler wont be able to provide accurate measurement at all.

Let me know if you need any more information. I have the screen shot of
wireshark and also the captured packets in pcap format . I dont know how to
upload though.

Thanks for your help,
Fei
Comment 1 peter lin 2006-10-13 13:54:18 UTC
Currently there is no plans to upgrade the soap sampler to Axis. I've thought
about using Axis, but just don't have the time these days to work on it. if
anyone wants to upgrade it to use axis, I can provide assistance.

peter
Comment 2 Sebb 2008-11-08 14:41:27 UTC
One can also use SOAP/XML-RPC sampler which does use httpclient