Bug 40874 - Example in section log4j cause double entries in log files
Example in section log4j cause double entries in log files
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Documentation
Unknown
All All
: P4 trivial (vote)
: ---
Assigned To: Tomcat Developers Mailing List
http://tomcat.apache.org/tomcat-5.5-d...
: PatchAvailable
: 41636 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2006-11-02 06:47 UTC by Franck Borel
Modified: 2007-02-16 16:24 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Franck Borel 2006-11-02 06:47:52 UTC
The example in the section log4j causes doubel entries in the log files. Delete
the last line to make it work properly:

            log4j.rootLogger=debug, R 
            log4j.appender.R=org.apache.log4j.RollingFileAppender 
            log4j.appender.R.File=${catalina.home}/logs/tomcat.log 
            log4j.appender.R.MaxFileSize=10MB 
            log4j.appender.R.MaxBackupIndex=10 
            log4j.appender.R.layout=org.apache.log4j.PatternLayout 
            log4j.appender.R.layout.ConversionPattern=%p %t %c - %m%n 
            log4j.logger.org.apache.catalina=DEBUG, R
must be changed in:
            log4j.rootLogger=debug, R 
            log4j.appender.R=org.apache.log4j.RollingFileAppender 
            log4j.appender.R.File=${catalina.home}/logs/tomcat.log 
            log4j.appender.R.MaxFileSize=10MB 
            log4j.appender.R.MaxBackupIndex=10 
            log4j.appender.R.layout=org.apache.log4j.PatternLayout 
            log4j.appender.R.layout.ConversionPattern=%p %t %c - %m%n
Comment 1 Mark Thomas 2006-11-10 17:43:57 UTC
Many thanks for the fix. It has been applied to SVN and will be included in
5.5.21 onwards.
Comment 2 Mark Thomas 2007-02-16 16:24:10 UTC
*** Bug 41636 has been marked as a duplicate of this bug. ***