Bug 40917 - configure does not detect OpenSSL shared lib on HP-UX
Summary: configure does not detect OpenSSL shared lib on HP-UX
Status: NEW
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.0.58
Hardware: HP HP-UX
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-07 07:50 UTC by Francois LAUPRETRE
Modified: 2006-11-07 07:50 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francois LAUPRETRE 2006-11-07 07:50:44 UTC
Note: bug for version 2.0.59 but the bug reporting form does not allow '2.0.59' 
as 'Version'.

If I build OpenSSL and install only its shared libraries, they have a '.sl' 
suffix on HP-UX. Then, when I run Apache's configure, it searches in turn a 
file named libssl.a, libssl.so, and libssl.dylib (line #10818 in 
2.0.59/configure). As I have not installed the static lib files, configure 
wrongly concludes that 'error: OpenSSL libraries not found'.

Workaround : configure should also search for a file named 'libssl.sl', in 
addition to the '.a', '.so', and '.dylib' suffixes.