Bug 41131 - Returning null while getting the value of formula cell value.
Summary: Returning null while getting the value of formula cell value.
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: unspecified
Hardware: Other other
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-07 23:25 UTC by Rajkumar G
Modified: 2006-12-08 02:58 UTC (History)
0 users



Attachments
Excell contains some formula cells (13.50 KB, application/vnd.ms-excel)
2006-12-07 23:28 UTC, Rajkumar G
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rajkumar G 2006-12-07 23:25:08 UTC
Hi, 
Im using poi-2.5.1-final-20040804.jar for read the excel file. In my excell file
some cell have formulas. When i trying to get the formula cell using
row.getCell(17) it's returning null(It's not return any values like 0 or empty). 
The code snippet is give bellow.
HSSFWorkbook wb = new HSSFWorkbook(new ByteArrayInputStream(excelFile));
HSSFSheet sheet = wb.getSheetAt(0);
row = sheet.getRow(0);
cell = row.getCell((short) 17); -- actually in my excel 17 th column have formula.

when i trying to take that it's returning null. 
Here with i'll attach the excel sheet also.

Can you please any one give a solution for this. I referred the same kind of
issues. but i don't find any solutions for this. Can you please help me this.
Comment 1 Rajkumar G 2006-12-07 23:28:27 UTC
Created attachment 19230 [details]
Excell contains some formula cells
Comment 2 Andy Oliver 2006-12-08 02:58:26 UTC
Since we do not calculate the values it is the expected behavior.  This is not
an appropriate forum to ask questions (for that you need to use the mail list)