Bug 41238 - apr_dir_read returns ENOENT instead of APR_ENOENT
Summary: apr_dir_read returns ENOENT instead of APR_ENOENT
Status: RESOLVED FIXED
Alias: None
Product: APR
Classification: Unclassified
Component: APR (show other bugs)
Version: HEAD
Hardware: All Solaris
: P5 trivial (vote)
Target Milestone: ---
Assignee: Apache Portable Runtime bugs mailinglist
URL:
Keywords: ErrorMessage, PatchAvailable
Depends on:
Blocks:
 
Reported: 2006-12-24 04:08 UTC by Lucian Adrian Grijincu
Modified: 2007-04-26 20:48 UTC (History)
0 users



Attachments
chane the return errorcode to apr_enoent (391 bytes, patch)
2006-12-24 04:09 UTC, Lucian Adrian Grijincu
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lucian Adrian Grijincu 2006-12-24 04:08:20 UTC
it's not a bug yet, just an inconsistency. it may become one when APR decides to
change the numbers that correspond to these errorcodes
Comment 1 Lucian Adrian Grijincu 2006-12-24 04:09:12 UTC
Created attachment 19302 [details]
chane the return errorcode to apr_enoent
Comment 2 William A. Rowe Jr. 2007-04-17 17:29:55 UTC
Good observation, fixed in trunk, no point in backporting since
this would only change at 2.0 apr.

Thanks for the patch!