Bug 41261 - org.apache.jasper.JasperException: File not found
Summary: org.apache.jasper.JasperException: File not found
Status: RESOLVED INVALID
Alias: None
Product: Tomcat 5
Classification: Unclassified
Component: Jasper (show other bugs)
Version: 5.5.9
Hardware: PC Linux
: P2 major (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on: 39817
Blocks:
  Show dependency tree
 
Reported: 2006-12-29 09:22 UTC by Muthukumar
Modified: 2006-12-29 21:00 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Muthukumar 2006-12-29 09:22:07 UTC
After upgrading the version of tomcat from 5.0 to 5.5.17 and java 1.4 to java 
1.5,most of the request in my webapp results like the following

org.apache.jasper.JasperException: /resource.jsp(4,0) File "/jsps/Header.jsp" 
not found
	org.apache.jasper.servlet.JspServletWrapper.handleJspException
(JspServletWrapper.java:510)
	org.apache.jasper.servlet.JspServletWrapper.service
(JspServletWrapper.java:375)
	org.apache.jasper.servlet.JspServlet.serviceJspFile
(JspServlet.java:314)
	org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


root cause 

org.apache.jasper.JasperException: /resource.jsp(4,0) File "/jsps/Header.jsp" 
not found
	org.apache.jasper.compiler.DefaultErrorHandler.jspError
(DefaultErrorHandler.java:39)


after the version change the above errors are output.After debugging found the 
root cause is related to the context root in which the application  is 
running..my appln structure is as below



web
 |
 ---jsps
     |
     |-----adminuser
     |           |
     |           ----admin.jsp
     |
     |
     |--header.jsp
     |--resource.sjp


the context root in which my appln run is web.The header.jsp is included in 
all jsp's using <%@include file="/jsps/header.jsp" %> 
from resource.jsp iam able to request the adminuser/admin.jsp.When the request 
is made from the admin.jsp to call resource.jsp using a hypherlink
(<html:link href="./jsps/resource.jsp"> HomeA</html:link>)

it results the above error.i have searched in the web..i can't get the exact 
resolution to fix this issue.Can anyone of you help me to fix it.
But the above said application is running fine in tomcat 5.0.
Comment 1 Mark Thomas 2006-12-29 21:00:51 UTC
A couple of points.

First, it is rude to add people who have not asked to be added to the cc list of
a bug report. Please do not do this in future.

Second Bugzilla is not a support forum - you should use the users list.

Finally, this looks like a appBase / docBase configuration issue. appBase should
never equal docBase. Please ask on the users list if you require more help.