Bug 41379 - VerifyError on FopFactory.newInstance() using Tomcat 5.5.17 and JDK 1.5.0_07
Summary: VerifyError on FopFactory.newInstance() using Tomcat 5.5.17 and JDK 1.5.0_07
Status: NEW
Alias: None
Product: Fop - Now in Jira
Classification: Unclassified
Component: general (show other bugs)
Version: 0.93
Hardware: PC Windows XP
: P3 normal
Target Milestone: ---
Assignee: fop-dev
Keywords: ErrorMessage
Depends on:
Reported: 2007-01-16 07:06 UTC by Aaron Meyer
Modified: 2012-04-07 01:39 UTC (History)
3 users (show)


Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Meyer 2007-01-16 07:06:33 UTC
Trying to convert 0.20.5 to fop-0.93-bin-jdk1.4.zip (1/3/2007).  0.20.5 worked 
fine other than 'Out of Memory' exceptions.  0.93 generates the following error 
when FopFactory.newInstance() is called during my PDFGenerator class's initial 

java.lang.VerifyError: (class: org/apache/fop/fo/ElementMappingRegistry, 
method: findFOMaker signature: 
Lorg/apache/fop/fo/ElementMapping$Maker;) Wrong return type in function

Tried downloading from 2 different mirror sites.  I'm using Eclipse 3.1.2 (with 
MyEclipse Tomcat Server configuration).  Configured Eclipse/MyEclipse to use 
jdk 1.5.0_07 for Tomcat and Eclipse compiler, but Eclipse compiler is set to 
compliance level 1.4.

FopFactory is private as in your Servlets Example although not in a servlet:
private FopFactory fopFactory = FopFactory.newInstance();
private TransformerFactory tFactory = TransformerFactory.newInstance();

Didn't install xalan, xercesImpl, xml-apis, or serializer jars (using jdk's xml 
funcitonality instead), although that seems irrelevant for this. 

Perhaps 0.93 isn't compatible with java 5.0?  Seems like it should be - the 
older 0.20.5 version works. 

I hope I'm not overlooking something and that this is enough information.
Comment 1 Massimo Finocchietti 2007-06-12 01:39:35 UTC
Exactly the same error.

I'm using MyEclipse 5.1.0 GA and developing on JDK 1.4.2_12 and with the 0.20.5
FOP version I've never 

I've downloaded the source, compiled it and linked to my project to be able to
debugging, and I've noticed that it never enters in findFOMaker method. I've
setted breakpoints and syso commands but nothing to do: the execution seems to
not enter in the method.
Comment 2 Arumugham GR 2007-06-18 02:25:50 UTC
Same error here too.

I was working with FOP 0.20.5 and everything was working fine except that I 
couldnt delete the images after embedding them into pdf.

So I wanted to move to FOP 0.93. I replaced fop.jar, common-io, xml-apis, 
common-lang, xalan, xerecesImpl jars into my workspace.

When I ran the code for the first time, I get the same error. And I verified 
thro debugging the src too, as Massimo Finocchietti has told, execution does 
not get into that method.

Kindly keep me informed of the solutions or fixes.

Comment 3 Geert jan de Boer 2007-06-28 00:41:38 UTC
When I upgraded from fop 0.20.5 to fop 0.93 I had the same problem. The cause of
the problem was in the fact that there where some default libraries in the jboss
lib directory (fop.jar v0.20.5 and others) which conflicted with the libraries
of the new fop (0.93) in my ear file.

This caused 'bug' 41379 in my configuration, please check this in your own config
Comment 4 Glenn Adams 2012-04-07 01:37:22 UTC
resetting severity from major to normal pending further review
Comment 5 Glenn Adams 2012-04-07 01:39:42 UTC
resetting P1 open bugs to P3 pending further review