Bug 41493 - odd characters in admin webapp, inconfigurable connectors
odd characters in admin webapp, inconfigurable connectors
Product: Tomcat 5
Classification: Unclassified
Component: Webapps:Administration
PC Windows Server 2003
: P3 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
Depends on:
  Show dependency tree
Reported: 2007-01-29 19:48 UTC by Gergely Zayzon
Modified: 2007-02-10 12:21 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Gergely Zayzon 2007-01-29 19:48:14 UTC
Just installed the (stable?) 5.5.20 binary distribution (apache-tomcat-
5.5.20.exe) using the included installer (custom install, took out the 
examples, docs, etc.), worked fine (with JRE 5.0.11 and later 5.0.10). Deployed 
the admin webapp (apache-tomcat-5.5.20-admin.zip) nicelly, which was working as 
expected, except two odd things:

1.) All connectors were appearing as HTTPS connectors regardless of their real 
type; when adding a new one, the selection of the type was properly reflected 
on the available fields, but upon saving the connector, they were again 
displayed as HTTPS connectors. When Commiting Changes, all values were properly 
commited to the server.xml (an AJP connector was really saved as an AJP 
connector, regardless that the admin webapp displayed HTTPS)

2.) In all the context configurations the Session ID Initializer value was full 
with garbage characters (quite random, although looks to be fixed length), kind 
of binary dump.
ROOT:     ®Ÿéð&Ìocèæ™9ëBåèÍŠt�OXîºíŠb5 
/admin:   Þ¾¥óet×`™ÔN$²•Á©ÉÜ…ïÄ­P6âÛ^¡ùM
/manager: YEšæ*"ø\Lâ e;PhÀu²”µv&ª£¥„

Tried to install a little older different java runtime, took over a prooven 
working server.xml from an another server, deployed a different admin webapp 
(from 5.5.17), changed numerous things in the server.xml, but nothing helped.

Only workaround I could find was to downgrade to 5.5.17, where none of these 
can be observed.
Comment 1 Mark Thomas 2007-01-29 20:44:09 UTC
I have tested this with the latest version from svn and I can't reproduce this.
Neither can I see anything in the change log that relates to fixes in any of
these areas since the 5.5.20 release.

I also downloaded 5.5.20 and the admin webapp and did a clean install. The only
configuration change I made was to add the admin user to the both user. The
admin app worked as expected and I saw neither of the errors you describe.

This looks like a configuration issue but no obvious explanation comes to mind.
I suggest you use the tomcat users list for help in resolving this.
Comment 2 Gergely Zayzon 2007-01-30 03:43:12 UTC
My appologies for being short in writing down the circumstances, but in the 
meantime it turned out that the tcnative-1.dll (v1.1.4.0), which was enabled 
during the installation of the 5.5.20 (and was not used anymore when downgraded 
to 5.5.17) is causing this behavior, so I reopened this report.

To reproduce:
Install 5.5.20 using the installer, choose Custom install, and select the 
native.dll for installation. Deploy the admin webapp as usual.
Comment 3 Mark Thomas 2007-02-02 17:19:33 UTC
Confirmed with the latest native dll as well. The all https makes sense but the
session ID initializer is very strange. I'll take a closer look.
Comment 4 Mark Thomas 2007-02-10 12:21:13 UTC
1. Reporting all connectors as https is a bug that is now fixed in svn.

2. The odd characters for are the Session ID Initializer a result of using APR
to initialise the session Id generator. They are, as you observe, random and of
fixed length. This is intentional. See
for the code that creates this.