Bug 41861 - Tomcat Windows installer behaves unexpectedly
Tomcat Windows installer behaves unexpectedly
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
unspecified
PC Windows 2000
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-03-16 03:31 UTC by Hubert Kauker
Modified: 2014-02-17 13:57 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hubert Kauker 2007-03-16 03:31:23 UTC
Assume Tomcat 5.5 running on Windows.
Installation done using the Windows installer.
tomcat5w.exe is used to start/stop the service.

Tried to update to 6.0 using Windows installer, again.

The installer fails to see
-	Tomcat is running
-	version 5.5 is still installed.

The installer comes up with a message: Apache Tomcat Setup failed to install
Tomcat6 service. Check your settings and permissions. Ignore and continue anyway
(not recommended)?

This message is not clear.
What action are we to take? Should we continue even though it is not recommended?

When continuation is chosen, everything runs to completion where the option “Run
Apache Tomcat” is presented. When this option is taken, the result is:
Application System Error.
The requested service is not available. Unable to open the service ‘Tomcat6’.

It does not help simply to stop the running Tomcat 5.5
One must *uninstall* Tomcat 5.5 (in order to remove the Windows service).

Repeating the installation then succeeds.
The installer, however, should be able to handle this in an "integrated" way.
Comment 1 Tobias Freier 2007-07-11 07:54:24 UTC
The Problem ist that the display name of tomcat5.5 service and tomcat6 service
is 'Apache Tomcat'. So you can't use the exe installer from the tomcat if you
have already installed the other tomcat version (i need both versions on one
machine).

A workaround is to use the binary distribution in a zip file and use the
bin/service.bat to install the service. just rename the PR_DISPLAYNAME' variable
from 'Apache Tomcat' to 'Apache TomcatX' and you can install the tomcat as a
service.
I copied the tomcat monitor shortcut from the tomcat 6 installation and
customized it for the install dir of tomcat 5.5 so I can use ist to start/stop
tomcat (like this more than the .bat)

It would be great if you could rename the display name of the service in the
next version, so that we can use tomcat5.5 and tomcat6 as sevice on one machine.

tnx, Tobias Freier
Comment 2 Marco Rauch 2008-02-10 06:26:38 UTC
in order to use the apache-tomcat-6.0.16.exe installer and to avoid the
service creation error message i simply renamed my running "Apache Tomcat"
5.5 service with the sc command in a dos box:

sc config "tomcat5" DisplayName= "Apache Tomcat 5.5.20"
[SC] ChangeServiceConfig SUCCESS

Now, the apache-tomcat-6.0.16.exe installer runs as expected.

bye, marco
Comment 3 Mark Thomas 2008-11-03 06:32:39 UTC
I changed the service name to "Apache Tomcat 6". The full version number is still displayed in the description. This has been fixed in trunk and proposed for 6.0.x
Comment 4 Mark Thomas 2009-01-14 15:22:58 UTC
This has been fixed in 6.0.x and will be included in 6.0.19 onwards.
Comment 5 Sami Shaik 2011-01-03 23:59:54 UTC
Hi there,

Could anyone please tell me step by step procedure to install tomacat 6. I tried to install version 5,6 and 7 but i'm getting same error. Please help me to install tomcat it is very urgent.

Thanks,
Sami
Comment 6 Chuck Caldarale 2011-01-04 00:10:57 UTC
(In reply to comment #5)
> Could anyone please tell me step by step procedure to install tomacat 6. I
> tried to install version 5,6 and 7 but i'm getting same error. Please help me
> to install tomcat it is very urgent.

It's extremely obnoxious to hijack a bugzilla entry.  Bugzilla is not a support forum; if you have usage questions, ask them on the Tomcat users mailing list.