Bug 42039 - Tomcat doesn't output the stack trace of UnavailableException.
Tomcat doesn't output the stack trace of UnavailableException.
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Catalina
5.5.23
All All
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-04-03 16:54 UTC by kawasima
Modified: 2007-04-15 10:51 UTC (History)
0 users



Attachments
Tomcat outputs the stack trace with this patch. (789 bytes, patch)
2007-04-03 17:01 UTC, kawasima
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kawasima 2007-04-03 16:54:58 UTC
When UnavailableException is thrown from the Servlet:init, Tomcat doesn't output
the stack trace of UnavailableException.

The cause of problem is lost.

Tomcat should output the stack trace at the "invoke" method of
StandardWrapperValue.
Comment 1 kawasima 2007-04-03 17:01:44 UTC
Created attachment 19907 [details]
Tomcat outputs the stack trace with this patch.

Tomcat outputs the stack trace with this patch.
Comment 2 Mark Thomas 2007-04-15 10:51:24 UTC
Your patch has been applied to svn and will be included in 5.5.24 and 6.0.12
onwards.

Many thanks.