Bug 42040 - ab doesn't consider varying length documents
ab doesn't consider varying length documents
Status: RESOLVED DUPLICATE of bug 27888
Product: Apache httpd-2
Classification: Unclassified
Component: support
All Linux
: P2 normal with 2 votes (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
Depends on:
  Show dependency tree
Reported: 2007-04-03 19:27 UTC by Adam Peacock
Modified: 2013-10-10 09:56 UTC (History)
3 users (show)


Note You need to log in before you can comment on or make changes to this bug.
Description Adam Peacock 2007-04-03 19:27:19 UTC
Apache HTTP server benchmarking tool needs to have an option to ignore varying
length documents. This could be a flat ignore option, or threshold valued argument.

Why? In CGI environments the document length isn't necessarily sable.

On the first iteration of a bench test, ab saves the length of the document in a
variable called doclen. It then uses this as a comparison of what subsequent
document lengths should be. Therefore, if the page being tested isn't stable in
document length, the tool reports massive amounts of `Failed requests` due to

This makes the tool useless for sites that don't have documents of stable length.
Comment 1 febeling 2007-07-11 03:55:25 UTC
This was already the behaviour with the version that comes with apache 1.3. See #27888. Definitely 
broken I'd say. 
Comment 2 Olaf van der Spek 2013-01-31 19:49:49 UTC
+1 ;)
Comment 3 Christophe JAILLET 2013-06-01 09:00:26 UTC

*** This bug has been marked as a duplicate of bug 27888 ***
Comment 4 Olaf van der Spek 2013-06-01 09:05:46 UTC
Christophe, could you update and reopen #27888?
Comment 5 Christophe JAILLET 2013-06-01 10:13:01 UTC
No, because I get:
   You are not permitted to edit bugs in product Apache httpd-1.3. 

Anyway, I'll take the proposals in #9945, #42040 and #27888 and will apply it to trunk and propose to backport for 2.4.x

Having such a switch makes sense to me.