Bug 42181 - ArrayIndexOutOfBoundsException in parseChunkHeader
ArrayIndexOutOfBoundsException in parseChunkHeader
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Connector:Coyote
5.5.23
Other Linux
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 53752 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-04-21 22:48 UTC by Nana
Modified: 2012-10-01 09:44 UTC (History)
1 user (show)



Attachments
2012-08-28_tc6_42181.patch (11.93 KB, patch)
2012-08-28 00:50 UTC, Konstantin Kolinko
Details | Diff
2012-08-29_tc55_42181.patch (10.60 KB, patch)
2012-08-28 20:58 UTC, Konstantin Kolinko
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nana 2007-04-21 22:48:21 UTC
Apr 22, 2007 11:53:32 AM org.apache.coyote.http11.Http11Processor process
SEVERE: Error finishing request
java.lang.ArrayIndexOutOfBoundsException: -28
        at
org.apache.coyote.http11.filters.ChunkedInputFilter.parseChunkHeader(ChunkedInputFilter.java:256)
        at
org.apache.coyote.http11.filters.ChunkedInputFilter.doRead(ChunkedInputFilter.java:129)
        at
org.apache.coyote.http11.filters.ChunkedInputFilter.end(ChunkedInputFilter.java:179)
        at
org.apache.coyote.http11.InternalInputBuffer.endRequest(InternalInputBuffer.java:368)
        at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:894)
        at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
        at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
        at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
        at java.lang.Thread.run(Thread.java:595)
Comment 1 Remy Maucherat 2007-04-22 03:26:26 UTC
The HTTP request is most likely invalid.
Comment 2 Konstantin Kolinko 2012-08-27 22:54:41 UTC
*** Bug 53752 has been marked as a duplicate of this bug. ***
Comment 3 Konstantin Kolinko 2012-08-28 00:41:12 UTC
Fixed in Tomcat 7 with r1377909. It will be in 7.0.30.
Comment 4 Konstantin Kolinko 2012-08-28 00:50:53 UTC
Created attachment 29288 [details]
2012-08-28_tc6_42181.patch

Patch for Tomcat 6
Comment 5 Konstantin Kolinko 2012-08-28 20:58:49 UTC
Created attachment 29295 [details]
2012-08-29_tc55_42181.patch

Patch for Tomcat 5.5
Includes backport of r423453

The patches have been proposed for 6.0 and 5.5.
Comment 6 Konstantin Kolinko 2012-09-05 07:24:53 UTC
Fixed in 6.0 with r1381038. It will be in Tomcat 6.0.36 onwards.
Comment 7 Mark Thomas 2012-10-01 09:44:37 UTC
This has been fixed in 5.5.x and will be included in 5.5.36 onwards.