Bug 42314 - Jasper output no details with compilation error in specific case.
Jasper output no details with compilation error in specific case.
Status: RESOLVED FIXED
Product: Tomcat 5
Classification: Unclassified
Component: Jasper
5.5.23
Other Windows XP
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 42435 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-05-02 01:13 UTC by Suzuki Yuichiro
Modified: 2007-06-24 04:49 UTC (History)
1 user (show)



Attachments
Patch for Jasper to output details of the compile error. (8.63 KB, patch)
2007-05-02 01:15 UTC, Suzuki Yuichiro
Details | Diff
fix previous patch's bug (8.96 KB, patch)
2007-05-07 05:32 UTC, Suzuki Yuichiro
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Suzuki Yuichiro 2007-05-02 01:13:16 UTC
Jasper output no details when Jasper cannot find
mappings between generated servlet code (with mistakes)
and former JSP.
One example JSP is the following. 
(The imported class in the JSP is not found.)
---
<%@
  page import = "not.exist.class"
%>
---
Comment 1 Suzuki Yuichiro 2007-05-02 01:15:54 UTC
Created attachment 20085 [details]
Patch for Jasper to output details of the compile error.
Comment 2 Suzuki Yuichiro 2007-05-02 01:30:47 UTC
The patch corrects Jasper to output error details.
And it also fixes a bug that the InputStream was not closed.
Comment 3 Suzuki Yuichiro 2007-05-07 05:32:51 UTC
Created attachment 20140 [details]
fix previous patch's bug

The following problem of the previous patch were corrected:
When the exception is generated when calling the jsp servlet after the
compilation of JSP succeeds, details (information of the JSP source) become
null.
Comment 4 Mark Thomas 2007-05-16 15:38:10 UTC
*** Bug 42435 has been marked as a duplicate of this bug. ***
Comment 5 Mark Thomas 2007-06-24 04:49:16 UTC
Thanks for the report. This was already fixed in TC6 with an alternative patch
so I ported the TC6 fix to TC5.

I also added the code to close the input streams to TC5 and TC6.