Bug 42678 - docBase ignored even if its not a subdir of appBase
docBase ignored even if its not a subdir of appBase
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Catalina
unspecified
Other Linux
: P2 minor (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
: 46587 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2007-06-15 15:07 UTC by J
Modified: 2009-01-22 04:57 UTC (History)
1 user (show)



Attachments
fix docBase starting with same prefix as appBase (857 bytes, patch)
2007-06-15 15:09 UTC, J
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description J 2007-06-15 15:07:50 UTC
I use latest 6.0 SVN snapshot. I store deployable WARs in "webapps-dist" (aside
"webapps"). This is my setup:

bash-3.2$ ls $CATALINA_BASE 
conf  logs  temp  tomcat-dist  webapps  webapps-dist  work
bash-3.2$ ls  webapps-dist
sample.war
bash-3.2$ cat conf/Catalina/localhost/sample.xml
<Context docBase="${catalina.base}/webapps-dist/sample.war"/>

this ends up in: 

WARNUNG: A docBase /home/juergen/java/tomcat/webapps-dist/sample.war inside the
host appBase has been specified, and will be ignored
Comment 1 J 2007-06-15 15:09:06 UTC
Created attachment 20359 [details]
fix docBase starting with same prefix as appBase
Comment 2 Mark Thomas 2008-07-10 10:04:53 UTC
The patch has been applied to trunk and proposed for 6.0.x.

Sorry it took so long to get to this.
Comment 3 Mark Thomas 2008-11-03 06:29:43 UTC
This was fixed in r677709 and was included in 6.0.18 onwards
Comment 4 Konstantin Kolinko 2009-01-22 04:57:01 UTC
*** Bug 46587 has been marked as a duplicate of this bug. ***