Bug 4281 - Built in Ant task Delete follows symbolic links by default
Summary: Built in Ant task Delete follows symbolic links by default
Status: RESOLVED DUPLICATE of bug 1550
Alias: None
Product: Ant
Classification: Unclassified
Component: Core tasks (show other bugs)
Version: 1.4
Hardware: HP HP-UX
: P3 enhancement (vote)
Target Milestone: ---
Assignee: Ant Notifications List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2001-10-18 16:07 UTC by Colby Gooding
Modified: 2008-02-22 12:18 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colby Gooding 2001-10-18 16:07:33 UTC
The built-in Ant task 'Delete' appears to follow symbolic links by default 
without the option to not follow links.  Most programs on most unix systems 
either do not follow symbolic links by default and/or allow the option to 
follow symbolic links; it would be nice if Ant followed that same convention, 
at least giving the user the option before plastering files and directories 
that were links in the original delete path.
Comment 1 Magesh Umasankar 2001-10-18 17:21:58 UTC

*** This bug has been marked as a duplicate of 1550 ***